AtOnline API tools for Flutter
This package allows simple access to AtOnline APIs, such as user accounts (oauth2), and all the services provided by AtOnline.
[0.2.3] - August 16th 2019
- Fix AtOnlineApiResult data accessor
[0.2.2] - August 16th 2019
- Fix AtOnlineApiResult
[0.2.1] - August 16th 2019
- Make AtOnlineApiResult iterable
[0.2.0] - August 16th 2019
- Add AtOnlineApiResult object to simplify Api result data access
[0.1.1] - July 23rd 2019
- Fix for flutter 1.2+
[0.1.0] - March 19th 2019
- AndroidX upgrade (dependency version bump)
[0.0.3] - January 1st 2019
- Fix links API to handle query string in links correctly
[0.0.1] - December 29th 2018
- Initial release with API, user & links code.
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: atonline_api: ^0.2.3
2. Install it
You can install packages from the command line:
$ flutter pub get
Alternatively, your editor might support
flutter pub get.
Check the docs for your editor to learn more.
3. Import it
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Dec 7, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.6.1
- pana: 0.12.21
- Flutter: 1.9.1+hotfix.6
Detected platforms: Flutter
References Flutter, and has no conflicting libraries.
lib/src/links.dart. (-1 points)
lib/src/links.dart reported 2 hints:
line 18 col 10: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.
line 82 col 3: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.
flutter format to format
Maintenance issues and suggestions
Support latest dependencies. (-10 points)
The version constraint in
pubspec.yaml does not support the latest published versions for 1 dependency (
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package.
Common filename patterns include
atonline_api.dart. Packages with multiple examples should provide
For more information see the pub package layout conventions.
|Dart SDK||>=2.0.0-dev.68.0 <3.0.0|