atonline_api 0.2.5

  • Readme
  • Changelog
  • Installing
  • 46

atonline_api #

AtOnline API tools for Flutter

Purpose #

This package allows simple access to AtOnline APIs, such as user accounts (oauth2), and all the services provided by AtOnline.

[0.2.5] January 22nd 2020 #

  • Added support for context override in api

[0.2.4] January 22nd 2020 #

  • Upgrade dependencies for recent flutter

[0.2.3] - August 16th 2019 #

  • Fix AtOnlineApiResult data accessor

[0.2.2] - August 16th 2019 #

  • Fix AtOnlineApiResult

[0.2.1] - August 16th 2019 #

  • Make AtOnlineApiResult iterable

[0.2.0] - August 16th 2019 #

  • Add AtOnlineApiResult object to simplify Api result data access

[0.1.1] - July 23rd 2019 #

  • Fix for flutter 1.2+

[0.1.0] - March 19th 2019 #

  • AndroidX upgrade (dependency version bump)

[0.0.3] - January 1st 2019 #

  • Fix links API to handle query string in links correctly

[0.0.1] - December 29th 2018 #

  • Initial release with API, user & links code.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  atonline_api: ^0.2.5

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:atonline_api/atonline_api.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
46
Learn more about scoring.

We analyzed this package on Jul 7, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:atonline_api/atonline_api.dart, package:atonline_api/src/user.dart, package:atonline_api/src/links.dart, package:uni_links/uni_links.dart] that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because of import path [package:atonline_api/atonline_api.dart, package:atonline_api/src/user.dart, package:atonline_api/src/links.dart, package:uni_links/uni_links.dart] that declares support for platforms: android, ios

Package does not support Flutter platform web

Because of import path [package:atonline_api/atonline_api.dart, package:atonline_api/src/user.dart, package:atonline_api/src/links.dart, package:uni_links/uni_links.dart] that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because of import path [package:atonline_api/atonline_api.dart, package:atonline_api/src/user.dart, package:atonline_api/src/links.dart, package:uni_links/uni_links.dart] that declares support for platforms: android, ios

Package not compatible with SDK dart

because of import path [atonline_api] that is in a package requiring null.

Health suggestions

Fix lib/src/links.dart. (-1 points)

Analysis of lib/src/links.dart reported 2 hints:

line 18 col 10: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 82 col 3: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (uni_links).

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and atonline_api.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
flutter_localizations 0.0.0
flutter_secure_storage ^3.3.1 3.3.3
http ^0.12.0 0.12.1
intl ^0.16.0 0.16.1
mime ^0.9.6+3 0.9.6+3
uni_links ^0.2.0 0.2.0 0.4.0
url_launcher ^5.4.1 5.4.11
Transitive dependencies
charcode 1.1.3
collection 1.14.12 1.14.13
flutter_web_plugins 0.0.0
http_parser 3.1.4
meta 1.1.8 1.2.1
path 1.6.4 1.7.0
pedantic 1.9.0 1.9.1
platform_detect 1.4.0
plugin_platform_interface 1.0.2
pub_semver 1.4.4
sky_engine 0.0.99
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6 1.2.0
url_launcher_macos 0.0.1+7
url_launcher_platform_interface 1.0.7
url_launcher_web 0.1.2
vector_math 2.0.8
Dev dependencies
flutter_test