atonline_api 0.2.3

  • Readme
  • Changelog
  • Installing
  • 48

atonline_api #

AtOnline API tools for Flutter

Purpose #

This package allows simple access to AtOnline APIs, such as user accounts (oauth2), and all the services provided by AtOnline.

[0.2.3] - August 16th 2019

  • Fix AtOnlineApiResult data accessor

[0.2.2] - August 16th 2019

  • Fix AtOnlineApiResult

[0.2.1] - August 16th 2019

  • Make AtOnlineApiResult iterable

[0.2.0] - August 16th 2019

  • Add AtOnlineApiResult object to simplify Api result data access

[0.1.1] - July 23rd 2019

  • Fix for flutter 1.2+

[0.1.0] - March 19th 2019

  • AndroidX upgrade (dependency version bump)

[0.0.3] - January 1st 2019

  • Fix links API to handle query string in links correctly

[0.0.1] - December 29th 2018

  • Initial release with API, user & links code.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  atonline_api: ^0.2.3

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:atonline_api/atonline_api.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Oct 18, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/src/links.dart. (-1 points)

Analysis of lib/src/links.dart reported 2 hints:

line 18 col 10: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 82 col 3: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Format lib/src/api.dart.

Run flutter format to format lib/src/api.dart.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (intl).

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and atonline_api.dart. Packages with multiple examples should provide example/

For more information see the pub package layout conventions.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
flutter_localizations 0.0.0
flutter_secure_storage ^3.2.0 3.3.1+1
http ^0.12.0 0.12.0+2
intl ^0.15.7 0.15.8 0.16.0
mime ^0.9.6+2 0.9.6+3
uni_links ^0.2.0 0.2.0
url_launcher ^5.0.2 5.2.2
Transitive dependencies
async 2.4.0
charcode 1.1.2
collection 1.14.11 1.14.12
http_parser 3.1.3
meta 1.1.7
path 1.6.4
pedantic 1.8.0+1
sky_engine 0.0.99
source_span 1.5.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies