appflowy_editor 3.0.0 copy "appflowy_editor: ^3.0.0" to clipboard
appflowy_editor: ^3.0.0 copied to clipboard

A highly customizable rich-text editor for Flutter. The AppFlowy Editor project for AppFlowy and beyond.

353
likes
160/ 160
pub points
93%
popularity

We analyzed this package 10 hours ago, and awarded it 160 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected licenses: MPL-2.0, AGPL-3.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

745 out of 2191 API elements (34.0 %) have documentation comments.

Some symbols that are missing documentation: appflowy_editor.AFMobileIcon.afMobileIcons, appflowy_editor.AFMobileIcon.color, appflowy_editor.AFMobileIcon.size, appflowy_editor.AFMobileIcons, appflowy_editor.AFMobileIcons.AFMobileIcons.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:appflowy_editor/appflowy_editor.dart that imports:
  • package:appflowy_editor/src/editor/editor.dart that imports:
  • package:appflowy_editor/src/editor/toolbar/toolbar.dart that imports:
  • package:appflowy_editor/src/editor/toolbar/mobile/mobile.dart that imports:
  • package:appflowy_editor/src/editor/toolbar/mobile/mobile_toolbar_v2.dart that imports:
  • package:appflowy_editor/src/editor/toolbar/mobile/utils/keyboard_height_observer.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32_registry/win32_registry.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:appflowy_editor/appflowy_editor.dart that imports:
  • package:appflowy_editor/src/editor/editor.dart that imports:
  • package:appflowy_editor/src/editor/toolbar/toolbar.dart that imports:
  • package:appflowy_editor/src/editor/toolbar/mobile/mobile.dart that imports:
  • package:appflowy_editor/src/editor/toolbar/mobile/mobile_toolbar_v2.dart that imports:
  • package:appflowy_editor/src/editor/toolbar/mobile/utils/keyboard_height_observer.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32_registry/win32_registry.dart that declares support for platforms: Windows.
Package does not support platform `Windows`.

Because:

  • package:appflowy_editor/appflowy_editor.dart that imports:
  • package:appflowy_editor/src/editor/editor.dart that imports:
  • package:appflowy_editor/src/editor/toolbar/toolbar.dart that imports:
  • package:appflowy_editor/src/editor/toolbar/mobile/mobile.dart that imports:
  • package:appflowy_editor/src/editor/toolbar/mobile/mobile_toolbar_v2.dart that imports:
  • package:appflowy_editor/src/editor/toolbar/mobile/utils/keyboard_height_observer.dart that imports:
  • package:keyboard_height_plugin/keyboard_height_plugin.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:appflowy_editor/appflowy_editor.dart that imports:
  • package:appflowy_editor/src/editor/editor.dart that imports:
  • package:appflowy_editor/src/editor/toolbar/toolbar.dart that imports:
  • package:appflowy_editor/src/editor/toolbar/mobile/mobile.dart that imports:
  • package:appflowy_editor/src/editor/toolbar/mobile/mobile_toolbar_v2.dart that imports:
  • package:appflowy_editor/src/editor/toolbar/mobile/utils/keyboard_height_observer.dart that imports:
  • package:keyboard_height_plugin/keyboard_height_plugin.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:appflowy_editor/appflowy_editor.dart that imports:
  • package:appflowy_editor/src/editor/editor.dart that imports:
  • package:appflowy_editor/src/editor/toolbar/toolbar.dart that imports:
  • package:appflowy_editor/src/editor/toolbar/mobile/mobile.dart that imports:
  • package:appflowy_editor/src/editor/toolbar/mobile/mobile_toolbar_v2.dart that imports:
  • package:appflowy_editor/src/editor/toolbar/mobile/utils/keyboard_height_observer.dart that imports:
  • package:keyboard_height_plugin/keyboard_height_plugin.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:appflowy_editor/appflowy_editor.dart that imports:
  • package:appflowy_editor/src/editor/editor.dart that imports:
  • package:appflowy_editor/src/editor/toolbar/toolbar.dart that imports:
  • package:appflowy_editor/src/editor/toolbar/mobile/mobile.dart that imports:
  • package:appflowy_editor/src/editor/toolbar/mobile/mobile_toolbar_v2.dart that imports:
  • package:appflowy_editor/src/editor/toolbar/mobile/utils/keyboard_height_observer.dart that imports:
  • package:keyboard_height_plugin/keyboard_height_plugin.dart that declares support for platforms: Android, iOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.18.0 1.18.0 1.19.0
device_info_plus ^10.1.0 10.1.0 10.1.0
diff_match_patch ^0.4.1 0.4.1 0.4.1
file_picker ^8.0.2 8.0.5 8.0.5
flutter flutter 0.0.0 0.0.0
flutter_localizations flutter 0.0.0 0.0.0
flutter_svg ^2.0.6 2.0.10+1 2.0.10+1
html ^0.15.0 0.15.4 0.15.4
intl ^0.19.0 0.19.0 0.19.0
intl_utils ^2.8.2 2.8.7 2.8.7
keyboard_height_plugin ^0.0.4 0.0.5 0.0.5
logging ^1.2.0 1.2.0 1.2.0
markdown ^7.2.1 7.2.2 7.2.2
nanoid ^1.0.0 1.0.0 1.0.0
numerus ^2.1.2 2.2.0 2.2.0
path ^1.8.0 1.9.0 1.9.0
path_provider ^2.0.5 2.1.3 2.1.3
provider ^6.0.5 6.1.2 6.1.2
string_validator ^1.0.0 1.1.0 1.1.0
tuple ^2.0.1 2.0.2 2.0.2
universal_html ^2.2.4 2.2.4 2.2.4
url_launcher ^6.1.11 6.3.0 6.3.0
visibility_detector ^0.4.0+2 0.4.0+2 0.4.0+2
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 67.0.0 72.0.0
analyzer - 6.4.1 6.7.0
archive - 3.6.1 3.6.1
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
charcode - 1.3.1 1.3.1
clock - 1.1.1 1.1.1
convert - 3.1.1 3.1.1
cross_file - 0.3.4+1 0.3.4+1
crypto - 3.0.3 3.0.3
csslib - 1.0.0 1.0.0
dart_style - 2.3.6 2.3.6
device_info_plus_platform_interface - 7.0.0 7.0.0
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
flutter_plugin_android_lifecycle - 2.0.20 2.0.20
flutter_web_plugins - 0.0.0 0.0.0
glob - 2.1.2 2.1.2
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.1.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
nested - 1.0.0 1.0.0
package_config - 2.1.0 2.1.0
path_parsing - 1.0.1 1.0.1
path_provider_android - 2.2.6 2.2.6
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
petitparser - 6.0.2 6.0.2
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
pub_semver - 2.1.4 2.1.4
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
universal_io - 2.2.2 2.2.2
url_launcher_android - 6.3.3 6.3.3
url_launcher_ios - 6.3.0 6.3.0
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.2.0 3.2.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.1 2.3.1
url_launcher_windows - 3.1.1 3.1.1
vector_graphics - 1.1.11+1 1.1.11+1
vector_graphics_codec - 1.1.11+1 1.1.11+1
vector_graphics_compiler - 1.1.11+1 1.1.11+1
vector_math - 2.1.4 2.1.4
watcher - 1.1.0 1.1.0
web - 0.5.1 0.5.1
win32 - 5.5.1 5.5.1
win32_registry - 1.1.3 1.1.3
xdg_directories - 1.0.4 1.0.4
xml - 6.5.0 6.5.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.