zwap_design_system 0.1.358
zwap_design_system: ^0.1.358 copied to clipboard

This is a package to build a standard design system kit for any zwap projects

0
likes
90/ 130
pub points
57%
popularity

We analyzed this package 2 days ago, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 525 out of 916 API elements (57.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:zwap_design_system/zwap_design_system.dart that imports:
  • package:zwap_design_system/molecules/molecules.dart that imports:
  • package:zwap_design_system/molecules/resumeEditElements/zwapResumeEditElements.dart that imports:
  • package:zwap_design_system/atoms/atoms.dart that imports:
  • package:zwap_design_system/atoms/tag/zwapTag.dart that imports:
  • package:zwap_design_system/atoms/text/text.dart that imports:
  • package:zwap_design_system/atoms/text/multiStyle/zwapTextMultiStyle.dart that imports:
  • package:zwap_design_system/atoms/text/base/zwapText.dart that imports:
  • package:taastrap/taastrap.dart that imports:
  • package:taastrap/colStrap/colStrap.dart that imports:
  • package:taastrap/colStrap/components/row.dart that imports:
  • package:taastrap/colStrap/components/element.dart that imports:
  • package:taastrap/utils/utils.dart that imports:
  • package:zwap_utils/zwap_utils.dart that imports:
  • package:zwap_utils/zwap_utils/api/apiService.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 60 issues. Showing the first 2:

lib/atoms/atoms.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/atoms/bubble/zwapBubbleContainer.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.15.01.15.01.15.0
flutterflutter0.0.00.0.0
flutter_localizationsflutter0.0.00.0.0
flutter_svg^0.23.0+10.23.0+11.0.0
get_it^7.1.37.2.07.2.0
oktoast^3.1.3+13.1.43.1.5
provider^5.0.05.0.06.0.1
taastrap^0.1.290.1.290.1.29
zwap_utils^0.0.410.0.420.0.42
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
flutter_web_plugins-0.0.00.0.0
http-0.13.40.13.4
http_parser-4.0.04.0.0
intl-0.17.00.17.0
js-0.6.30.6.3
matcher-0.12.110.12.11
meta-1.7.01.7.0
nested-1.0.01.0.0
path-1.8.01.8.0
path_drawing-0.5.1+11.0.0
path_parsing-0.2.11.0.0
petitparser-4.4.04.4.0
quiver-3.0.1+13.0.1+1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
xml-5.3.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.23.0+1` on flutter_svg does not support the stable version `1.0.0`, that was published 0 days ago.

When flutter_svg is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions flutter_svg to update the constraint.

The constraint `^5.0.0` on provider does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions provider to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.