widget_toolkit 0.0.2 copy "widget_toolkit: ^0.0.2" to clipboard
widget_toolkit: ^0.0.2 copied to clipboard

The Widget Toolkit package consists of several lightweight and customisable UI components that boost productivity and reduce the development time.

48
likes
150/ 160
pub points
73%
popularity

We analyzed this package 4 days ago, and awarded it 150 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

254 out of 859 API elements (29.6 %) have documentation comments.

Some symbols that are missing documentation: Edit Address, Item Picker, Language Picker, Search Picker, Shimmer.

10/10 points: Package has an example and has no issues with screenshots

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: 'MaterialStateProperty' is deprecated and shouldn't be used. Use WidgetStateProperty instead. Moved to the Widgets layer to make code available outside of Material. This feature was deprecated after v3.19.0-0.3.pre.

lib/src/lib_ui_components/buttons/icon_text_button.dart:55:24

   ╷
55 │       backgroundColor: MaterialStateProperty.resolveWith((states) {
   │                        ^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/lib_ui_components/buttons/icon_text_button.dart

INFO: 'MaterialState' is deprecated and shouldn't be used. Use WidgetState instead. Moved to the Widgets layer to make code available outside of Material. This feature was deprecated after v3.19.0-0.3.pre.

lib/src/lib_ui_components/buttons/icon_text_button.dart:56:29

   ╷
56 │         if (states.contains(MaterialState.pressed) ||
   │                             ^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/lib_ui_components/buttons/icon_text_button.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
copy_with_extension ^5.0.3 5.0.4 5.0.4
equatable ^2.0.5 2.0.5 2.0.5
flutter flutter 0.0.0 0.0.0
flutter_localizations flutter 0.0.0 0.0.0
flutter_rx_bloc ^6.0.0 6.1.1 6.1.1
flutter_svg ^2.0.7 2.0.10+1 2.0.10+1
json_annotation ^4.8.1 4.9.0 4.9.0
provider ^6.0.5 6.1.2 6.1.2
rx_bloc ^5.0.0 5.0.3 5.0.3
rxdart ^0.27.7 0.27.7 0.28.0
shimmer ^3.0.0 3.0.0 3.0.0
theme_tailor_annotation ^3.0.0 3.0.1 3.0.1
url_launcher ^6.1.12 6.3.0 6.3.0
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.19.0
flutter_web_plugins - 0.0.0 0.0.0
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.1.0
intl - 0.19.0 0.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
nested - 1.0.0 1.0.0
path - 1.9.0 1.9.0
path_parsing - 1.0.1 1.0.1
petitparser - 6.0.2 6.0.2
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
url_launcher_android - 6.3.3 6.3.3
url_launcher_ios - 6.3.0 6.3.0
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.2.0 3.2.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.1 2.3.1
url_launcher_windows - 3.1.1 3.1.1
vector_graphics - 1.1.11+1 1.1.11+1
vector_graphics_codec - 1.1.11+1 1.1.11+1
vector_graphics_compiler - 1.1.11+1 1.1.11+1
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.27.7` on rxdart does not support the stable version `0.28.0`, that was published 6 days ago.

When rxdart is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions rxdart to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

48
likes
150
pub points
73%
popularity
screenshot

Publisher

verified publisherprimeholding.com

The Widget Toolkit package consists of several lightweight and customisable UI components that boost productivity and reduce the development time.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

copy_with_extension, equatable, flutter, flutter_localizations, flutter_rx_bloc, flutter_svg, json_annotation, provider, rx_bloc, rxdart, shimmer, theme_tailor_annotation, url_launcher

More

Packages that depend on widget_toolkit