videoframecapture 0.0.2 copy "videoframecapture: ^0.0.2" to clipboard
videoframecapture: ^0.0.2 copied to clipboard

Captures screenshot of video frame in flutter.

1
likes
110/ 140
pub points
22%
popularity

We analyzed this package 4 days ago, and awarded it 110 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL doesn't exist.

At the time of the analysis https://karunshrestha.com.np was unreachable. Make sure that the website is reachable via HEAD requests.

Repository URL doesn't exist.

At the time of the analysis https://github.com/karunstha/videoframecapture was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: videoframecapture,
    • contains a version property, and,
    • does not contain a publish_to property.

Unable to access git repository: Failed to run remote show origin.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

0 out of 14 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: videoframecapture, videoframecapture.VideoFrameCapture, videoframecapture.VideoFrameCapture.VideoFrameCapture, videoframecapture.VideoFrameCapture.capture, videoframecapture.VideoFrameCapture.chewieController.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:videoframecapture/videoframecapture.dart that imports:
  • package:video_player/video_player.dart that declares support for platforms: Android, iOS, macOS, Web.
Package does not support platform `Linux`.

Because:

  • package:videoframecapture/videoframecapture.dart that imports:
  • package:video_player/video_player.dart that declares support for platforms: Android, iOS, macOS, Web.
Package does not support platform `Web`.

Because:

  • package:videoframecapture/videoframecapture.dart that imports:
  • package:chewie/chewie.dart that imports:
  • package:chewie/src/material/material_desktop_controls.dart that imports:
  • package:chewie/src/chewie_player.dart that imports:
  • package:wakelock_plus/wakelock_plus.dart that imports:
  • package:wakelock_plus/src/wakelock_plus_linux_plugin.dart that imports:
  • package:dbus/dbus.dart that declares support for platforms: Windows, Linux.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:videoframecapture/videoframecapture.dart that imports:
  • package:chewie/chewie.dart that imports:
  • package:chewie/src/material/material_desktop_controls.dart that imports:
  • package:chewie/src/chewie_player.dart that imports:
  • package:wakelock_plus/wakelock_plus.dart that imports:
  • package:wakelock_plus/src/wakelock_plus_windows_plugin.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:videoframecapture/videoframecapture.dart that imports:
  • package:chewie/chewie.dart that imports:
  • package:chewie/src/material/material_desktop_controls.dart that imports:
  • package:chewie/src/chewie_player.dart that imports:
  • package:wakelock_plus/wakelock_plus.dart that imports:
  • package:wakelock_plus/src/wakelock_plus_windows_plugin.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:videoframecapture/videoframecapture.dart that imports:
  • package:chewie/chewie.dart that imports:
  • package:chewie/src/material/material_desktop_controls.dart that imports:
  • package:chewie/src/chewie_player.dart that imports:
  • package:wakelock_plus/wakelock_plus.dart that imports:
  • package:wakelock_plus/src/wakelock_plus_windows_plugin.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
chewie ^1.7.5 1.8.1 1.8.1
cupertino_icons ^1.0.6 1.0.8 1.0.8
flutter flutter 0.0.0 0.0.0
flutter_screenutil ^5.9.0 5.9.1 5.9.1
screenshot ^2.3.0 2.5.0 3.0.0
video_player ^2.8.6 2.8.6 2.8.6
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
csslib - 1.0.0 1.0.0
dbus - 0.7.10 0.7.10
ffi - 2.1.2 2.1.2
flutter_web_plugins - 0.0.0 0.0.0
html - 0.15.4 0.15.4
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
nested - 1.0.0 1.0.0
package_info_plus - 8.0.0 8.0.0
package_info_plus_platform_interface - 3.0.0 3.0.0
path - 1.9.0 1.9.0
petitparser - 6.0.2 6.0.2
plugin_platform_interface - 2.1.8 2.1.8
provider - 6.1.2 6.1.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
video_player_android - 2.4.14 2.4.14
video_player_avfoundation - 2.6.1 2.6.1
video_player_platform_interface - 6.2.2 6.2.2
video_player_web - 2.3.0 2.3.0
wakelock_plus - 1.2.5 1.2.5
wakelock_plus_platform_interface - 1.2.1 1.2.1
web - 0.5.1 0.5.1
win32 - 5.5.1 5.5.1
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.3.0` on screenshot does not support the stable version `3.0.0`, that was published 1 days ago.

When screenshot is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions screenshot to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.