versionarte 1.2.0 copy "versionarte: ^1.2.0" to clipboard
versionarte: ^1.2.0 copied to clipboard

Force update, show update indicator and disable the app for maintenance with total freedom over the UI.

62
likes
160/ 160
pub points
82%
popularity

We analyzed this package 19 hours ago, and awarded it 160 pub points (of a possible 160):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/kamranbekirovyz/versionarte/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

41 out of 57 API elements (71.9 %) have documentation comments.

Some symbols that are missing documentation: versionarte, versionarte.RemoteConfigVersionarteProvider.initializeInternally, versionarte.RemoteConfigVersionarteProvider.keyName, versionarte.RemoteConfigVersionarteProvider.remoteConfigSettings, versionarte.StatusDetails.active.

10/10 points: Package has an example and has no issues with screenshots

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:versionarte/versionarte.dart that imports:
  • package:versionarte/src/providers/remote_config_versionarte_provider.dart that imports:
  • package:firebase_remote_config/firebase_remote_config.dart that declares support for platforms: Android, iOS, macOS, Web.
Package does not support platform `Linux`.

Because:

  • package:versionarte/versionarte.dart that imports:
  • package:versionarte/src/providers/remote_config_versionarte_provider.dart that imports:
  • package:firebase_remote_config/firebase_remote_config.dart that declares support for platforms: Android, iOS, macOS, Web.
Package not compatible with platform Web

Because:

  • package:versionarte/versionarte.dart that imports:
  • package:versionarte/src/models/store_versioning.dart that imports:
  • dart:io

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:versionarte/versionarte.dart that imports:
  • package:versionarte/src/versionarte.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:versionarte/versionarte.dart that imports:
  • package:versionarte/src/versionarte.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:versionarte/versionarte.dart that imports:
  • package:versionarte/src/versionarte.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
firebase_remote_config ^5.0.2 5.0.3 5.0.3
flutter flutter 0.0.0 0.0.0
http ^1.2.1 1.2.2 1.2.2
package_info_plus ^8.0.0 8.0.0 8.0.0
pub_semver ^2.1.4 2.1.4 2.1.4
url_launcher ^6.3.0 6.3.0 6.3.0
Transitive dependencies
Package Constraint Compatible Latest
_flutterfire_internals - 1.3.39 1.3.39
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.19.0
fake_async - 1.3.1 1.3.1
ffi - 2.1.2 2.1.2
firebase_core - 3.2.0 3.2.0
firebase_core_platform_interface - 5.1.0 5.1.0
firebase_core_web - 2.17.3 2.17.3
firebase_remote_config_platform_interface - 1.4.39 1.4.39
firebase_remote_config_web - 1.6.11 1.6.11
flutter_test - 0.0.0 0.0.0
flutter_web_plugins - 0.0.0 0.0.0
http_parser - 4.0.2 4.1.0
leak_tracker - 10.0.4 10.0.5
leak_tracker_flutter_testing - 3.0.3 3.0.5
leak_tracker_testing - 3.0.1 3.0.1
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
package_info_plus_platform_interface - 3.0.0 3.0.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.3.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.3
typed_data - 1.3.2 1.3.2
url_launcher_android - 6.3.4 6.3.4
url_launcher_ios - 6.3.1 6.3.1
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.2.0 3.2.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.1 2.3.1
url_launcher_windows - 3.1.1 3.1.1
vector_math - 2.1.4 2.1.4
vm_service - 14.2.1 14.2.4
web - 0.5.1 1.0.0
win32 - 5.5.1 5.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

62
likes
160
pub points
82%
popularity
screenshot

Publisher

verified publisherkamranbekirov.com

Force update, show update indicator and disable the app for maintenance with total freedom over the UI.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (license)

Dependencies

firebase_remote_config, flutter, http, package_info_plus, pub_semver, url_launcher

More

Packages that depend on versionarte