vercel_edge 0.0.4+4 copy "vercel_edge: ^0.0.4+4" to clipboard
vercel_edge: ^0.0.4+4 copied to clipboard

Write and deploy Dart functions to the Vercel Edge network.

1
likes
100/ 140
pub points
13%
popularity

We analyzed this package 18 hours ago, and awarded it 100 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

129 out of 367 API elements (35.1 %) have documentation comments.

Some symbols that are missing documentation: request, request.IncomingRequestVercelProperties, request.IncomingRequestVercelProperties.city, request.IncomingRequestVercelProperties.country, request.IncomingRequestVercelProperties.countryRegion.

10/10 points: Package has an example

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Supports 0 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:vercel_edge/vercel_edge.dart that imports:
  • package:vercel_edge/public/request.dart that imports:
  • package:vercel_edge/interop/request_interop.dart that imports:
  • package:js_bindings/js_bindings.dart that imports:
  • package:js_bindings/bindings/all_bindings.dart that imports:
  • package:js_bindings/bindings/css_fonts_4.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform iOS

Because:

  • package:vercel_edge/vercel_edge.dart that imports:
  • package:vercel_edge/public/request.dart that imports:
  • package:vercel_edge/interop/request_interop.dart that imports:
  • package:js_bindings/js_bindings.dart that imports:
  • package:js_bindings/bindings/all_bindings.dart that imports:
  • package:js_bindings/bindings/css_fonts_4.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform Windows

Because:

  • package:vercel_edge/vercel_edge.dart that imports:
  • package:vercel_edge/public/request.dart that imports:
  • package:vercel_edge/interop/request_interop.dart that imports:
  • package:js_bindings/js_bindings.dart that imports:
  • package:js_bindings/bindings/all_bindings.dart that imports:
  • package:js_bindings/bindings/css_fonts_4.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform Linux

Because:

  • package:vercel_edge/vercel_edge.dart that imports:
  • package:vercel_edge/public/request.dart that imports:
  • package:vercel_edge/interop/request_interop.dart that imports:
  • package:js_bindings/js_bindings.dart that imports:
  • package:js_bindings/bindings/all_bindings.dart that imports:
  • package:js_bindings/bindings/css_fonts_4.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform macOS

Because:

  • package:vercel_edge/vercel_edge.dart that imports:
  • package:vercel_edge/public/request.dart that imports:
  • package:vercel_edge/interop/request_interop.dart that imports:
  • package:js_bindings/js_bindings.dart that imports:
  • package:js_bindings/bindings/all_bindings.dart that imports:
  • package:js_bindings/bindings/css_fonts_4.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform Web

Because:

  • package:vercel_edge/vercel_edge.dart that imports:
  • package:edge_runtime/edge_runtime.dart that imports:
  • package:edge_runtime/src/io_http_client.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
edge ^0.0.7 0.0.7 0.0.7
edge_runtime ^0.0.4+2 0.0.4+2 0.0.4+2
js ^0.6.5 0.6.7 0.7.1
js_bindings ^0.1.0 0.1.2+2 0.1.2+2
shelf ^1.4.0 1.4.1 1.4.1
Transitive dependencies
Package Constraint Compatible Latest
ansi_styles - 0.3.2+1 0.3.2+1
archive - 3.4.10 3.4.10
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
charcode - 1.3.1 1.3.1
checked_yaml - 2.0.3 2.0.3
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
freezed_annotation - 2.4.1 2.4.1
glob - 2.1.2 2.1.2
hotreloader - 3.0.6 4.2.0
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
io - 1.0.4 1.0.4
json_annotation - 4.8.1 4.8.1
logging - 1.2.0 1.2.0
mason - 0.1.0-dev.52 0.1.0-dev.52
mason_logger - 0.2.12 0.2.12
meta - 1.14.0 1.14.0
mustache_template - 2.0.0 2.0.0
path - 1.9.0 1.9.0
petitparser - 5.4.0 6.0.2
pointycastle - 3.8.0 3.8.0
pool - 1.5.1 1.5.1
prompts - 2.0.0 2.0.0
pub_semver - 2.1.4 2.1.4
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
stream_transform - 2.1.0 2.1.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
toml - 0.13.1 0.15.0
typed_data - 1.3.2 1.3.2
vm_service - 11.10.0 14.2.1
watcher - 1.1.0 1.1.0
web - 0.5.1 0.5.1
win32 - 5.4.0 5.4.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.6.5` on js does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions js to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.3.3.

Check the analysis log for details.

1
likes
100
pub points
13%
popularity

Publisher

verified publisherinvertase.io

Write and deploy Dart functions to the Vercel Edge network.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

edge, edge_runtime, js, js_bindings, shelf

More

Packages that depend on vercel_edge