surveysparrow_flutter_sdk 1.0.0-beta.5 icon indicating copy to clipboard operation
surveysparrow_flutter_sdk: ^1.0.0-beta.5 copied to clipboard

SurveySparrow's flutter SDK lets you collect feedback at various touchpoints from your mobile app users. You can easily embed surveys in your mobile app with a few lines of code.

5
likes
100/ 130
pub points
53%
popularity

We analyzed this package 3 days ago, and awarded it 100 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 22 out of 685 API elements (3.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:surveysparrow_flutter_sdk/eui.dart that imports:
  • package:surveysparrow_flutter_sdk/helpers/answers.dart that imports:
  • package:ua_client_hints/ua_client_hints.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:surveysparrow_flutter_sdk/eui.dart that imports:
  • package:surveysparrow_flutter_sdk/helpers/answers.dart that imports:
  • package:ua_client_hints/ua_client_hints.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:surveysparrow_flutter_sdk/eui.dart that imports:
  • package:surveysparrow_flutter_sdk/helpers/answers.dart that imports:
  • package:ua_client_hints/ua_client_hints.dart that declares support for platforms: Android, iOS.
Package not compatible with platform Web

Because:

  • package:surveysparrow_flutter_sdk/components/common/bottomNavigation.dart that imports:
  • package:flutter_svg/flutter_svg.dart that imports:
  • package:flutter_svg/svg.dart that imports:
  • package:flutter_svg/src/picture_provider.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 193 issues. Showing the first 2:

INFO: The value of the local variable 'bottomPadding' isn't used.

lib/components/common/bottomNavigation.dart:65:9

   ╷
65 │     var bottomPadding = window.viewPadding.bottom;
   │         ^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/components/common/bottomNavigation.dart

INFO: The import of 'dart:ui' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/material.dart'.

lib/components/common/footer.dart:1:8

  ╷
1 │ import 'dart:ui';
  │        ^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/components/common/footer.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
country_code_picker^2.0.22.0.22.0.2
country_pickers^2.0.02.0.02.0.0
easy_debounce^2.0.2+12.0.2+12.0.2+1
eval_ex^1.1.61.1.61.1.6
expandable_text^2.3.02.3.02.3.0
fk_user_agent^2.1.02.1.02.1.0
flutterflutter0.0.00.0.0
flutter_rating_stars^1.0.3+41.0.3+41.0.3+4
flutter_spinkit^5.1.05.1.05.1.0
flutter_svg^0.22.00.22.01.1.3
http^0.13.40.13.50.13.5
phone_numbers_parser^5.0.05.0.56.0.0
readmore^2.1.02.2.02.2.0
sizer^2.0.152.0.152.0.15
ua_client_hints^1.1.01.1.11.1.1
url_launcher^6.1.16.1.56.1.5
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.9.02.9.0
characters-1.2.01.2.1
collection-1.16.01.16.0
crypto-3.0.23.0.2
dart_countries-3.0.23.0.2
decimal-2.2.02.2.0
flutter_web_plugins-0.0.00.0.0
http_parser-4.0.14.0.1
js-0.6.40.6.4
material_color_utilities-0.1.40.2.0
meta-1.7.01.8.0
modal_bottom_sheet-2.1.02.1.0
path-1.8.21.8.2
path_drawing-0.5.1+11.0.1
path_parsing-0.2.11.0.1
petitparser-5.0.05.0.0
phone_number_metadata-5.0.35.0.3
plugin_platform_interface-2.1.22.1.2
rational-2.2.02.2.0
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
universal_io-2.0.42.0.4
universal_platform-1.0.0+11.0.0+1
url_launcher_android-6.0.176.0.17
url_launcher_ios-6.0.176.0.17
url_launcher_linux-3.0.13.0.1
url_launcher_macos-3.0.13.0.1
url_launcher_platform_interface-2.1.02.1.0
url_launcher_web-2.0.132.0.13
url_launcher_windows-3.0.13.0.1
vector_math-2.1.22.1.2
xml-5.4.16.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.22.0` on flutter_svg does not support the stable version `0.23.0`.

Try running dart pub upgrade --major-versions flutter_svg to update the constraint.

The constraint `^5.0.0` on phone_numbers_parser does not support the stable version `6.0.0`, that was published 11 days ago.

When phone_numbers_parser is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions phone_numbers_parser to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.14, Flutter 3.0.4, Dart 2.17.5.

5
likes
100
pub points
53%
popularity

Publisher

verified publisher iconsurveysparrow.com

SurveySparrow's flutter SDK lets you collect feedback at various touchpoints from your mobile app users. You can easily embed surveys in your mobile app with a few lines of code.

Homepage

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

country_code_picker, country_pickers, easy_debounce, eval_ex, expandable_text, fk_user_agent, flutter, flutter_rating_stars, flutter_spinkit, flutter_svg, http, phone_numbers_parser, readmore, sizer, ua_client_hints, url_launcher

More

Packages that depend on surveysparrow_flutter_sdk