sass 1.29.0
sass: ^1.29.0

Dart native
Flutter Android iOS

A Sass implementation in Dart.

6
likes
65 / 110
pub points
92 %
popularity

We analyzed this package on Dec 3, 2020, and awarded it 65 pub points (of a possible 110):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:223:38

    ╷
223 │ market share of browser according to <a href="http://gs.statcounter.com/">StatCounter GlobalStats</a>, we may release
    │                                      ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 137 out of 147 API elements (93.2 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:sass/sass.dart that imports:
  • package:sass/src/value/external/value.dart that imports:
  • package:sass/src/value/external/list.dart that imports:
  • package:sass/src/value.dart that imports:
  • package:sass/src/visitor/serialize.dart that imports:
  • package:sass/src/visitor/interface/selector.dart that imports:
  • package:sass/src/ast/selector.dart that imports:
  • package:sass/src/ast/selector/simple.dart that imports:
  • package:sass/src/parse/selector.dart that imports:
  • package:sass/src/parse/parser.dart that imports:
  • package:sass/src/logger.dart that imports:
  • package:sass/src/logger/stderr.dart that imports:
  • package:sass/src/io.dart that imports:
  • package:sass/src/io/node.dart that imports:
  • package:watcher/watcher.dart that imports:
  • package:watcher/src/file_watcher/polling.dart that imports:
  • package:watcher/src/stat.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 32 issues. Showing the first 2:

INFO: `Future` results in `async` function bodies must be `await`ed or marked `unawaited` using `package:pedantic`.

lib/src/executable/watch.dart:50:7

   ╷
50 │       dirWatcher.events.listen(null).cancel();
   │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/executable/watch.dart

INFO: The diagnostic 'unused_import' doesn't need to be ignored here because it's already being ignored.

lib/src/import_cache.dart:23:33

   ╷
23 │ import 'utils.dart'; // ignore: unused_import
   │                                 ^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/import_cache.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args>=1.4.0 <2.0.01.6.01.6.0
async>=1.10.0 <3.0.02.4.22.4.2
charcode^1.1.01.1.31.1.3
cli_repl>=0.1.3 <0.3.00.2.0+10.2.0+1
collection^1.8.01.14.131.14.13
js^0.6.00.6.20.6.2
meta^1.1.71.2.41.2.4
node_interop^1.1.01.2.11.2.1
package_resolver^1.0.01.0.101.0.10
path^1.6.01.7.01.7.0
source_maps^0.10.50.10.90.10.9
source_span^1.6.01.7.01.7.0
stack_trace>=0.9.0 <2.0.01.9.61.9.6
stream_transform>=0.0.20 <2.0.01.2.01.2.0
string_scanner>=0.1.5 <2.0.01.0.51.0.5
term_glyph^1.0.01.1.01.1.0
tuple^1.0.01.0.31.0.3
watcher^0.9.60.9.7+150.9.7+15
Transitive dependencies
PackageConstraintCompatibleLatest
http-0.12.20.12.2
http_parser-3.1.43.1.4
matcher-0.12.90.12.9
package_config-1.9.31.9.3
quiver-2.1.52.1.5
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs