safexpay 0.0.9 icon indicating copy to clipboard operation
safexpay: ^0.0.9 copied to clipboard

A new Flutter plugin to create payment gateway using SafexPay

15
likes
100/ 130
pub points
58%
popularity

We analyzed this package 14 hours ago, and awarded it 100 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 49 out of 722 API elements (6.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:safexpay/safexpay.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:safexpay/safexpay.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:safexpay/safexpay.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:safexpay/safexpay.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:safexpay/safexpay.dart that imports:
  • package:safexpay/screen_1.dart that imports:
  • package:safexpay/PaymentMode.dart that imports:
  • package:safexpay/logic/safex_pay_bloc.dart that imports:
  • package:safexpay/make_payment_webview.dart that imports:
  • package:webview_flutter/webview_flutter.dart that imports:
  • package:webview_flutter/src/webview.dart that imports:
  • package:webview_flutter_wkwebview/webview_flutter_wkwebview.dart that declares support for platforms: iOS.
Package does not support platform `iOS`.

Because:

  • package:safexpay/safexpay.dart that imports:
  • package:safexpay/screen_1.dart that imports:
  • package:safexpay/PaymentMode.dart that imports:
  • package:safexpay/logic/safex_pay_bloc.dart that imports:
  • package:safexpay/make_payment_webview.dart that imports:
  • package:webview_flutter/webview_flutter.dart that imports:
  • package:webview_flutter/src/webview.dart that imports:
  • package:webview_flutter_android/webview_android_cookie_manager.dart that declares support for platforms: Android.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 134 issues. Showing the first 2:

INFO: The import of 'package:flutter/cupertino.dart' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/material.dart'.

lib/AppHeader.dart:1:8

  ╷
1 │ import 'package:flutter/cupertino.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/AppHeader.dart

INFO: Unused import: 'constants/strings.dart'.

lib/NetBanking.dart:13:8

   ╷
13 │ import 'constants/strings.dart';
   │        ^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/NetBanking.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
connectivity^3.0.63.0.63.0.6
encrypt^5.0.05.0.15.0.1
flutterflutter0.0.00.0.0
http^0.13.30.13.40.13.4
modal_progress_hud_nsn^0.1.0-nullsafety-10.1.0-nullsafety-10.1.0-nullsafety-1
rxdart^0.27.10.27.30.27.3
shared_preferences^2.0.62.0.152.0.15
webview_flutter^2.0.102.8.03.0.4
Transitive dependencies
PackageConstraintCompatibleLatest
args-2.3.12.3.1
asn1lib-1.1.01.1.0
async-2.9.02.9.0
characters-1.2.01.2.1
clock-1.1.01.1.0
collection-1.16.01.16.0
connectivity_for_web-0.4.0+10.4.0+1
connectivity_macos-0.2.1+20.2.1+2
connectivity_platform_interface-2.0.12.0.1
convert-3.0.13.0.1
crypto-3.0.23.0.2
ffi-1.2.11.2.1
file-6.1.26.1.2
flutter_web_plugins-0.0.00.0.0
http_parser-4.0.14.0.1
js-0.6.40.6.4
material_color_utilities-0.1.40.1.5
meta-1.7.01.8.0
path-1.8.21.8.2
path_provider_linux-2.1.62.1.6
path_provider_platform_interface-2.0.42.0.4
path_provider_windows-2.0.62.0.6
platform-3.1.03.1.0
plugin_platform_interface-2.1.22.1.2
pointycastle-3.6.03.6.0
process-4.2.44.2.4
shared_preferences_android-2.0.122.0.12
shared_preferences_ios-2.1.12.1.1
shared_preferences_linux-2.1.12.1.1
shared_preferences_macos-2.0.42.0.4
shared_preferences_platform_interface-2.0.02.0.0
shared_preferences_web-2.0.42.0.4
shared_preferences_windows-2.1.12.1.1
sky_engine-0.0.990.0.99
source_span-1.9.01.9.0
string_scanner-1.1.11.1.1
term_glyph-1.2.01.2.0
typed_data-1.3.11.3.1
vector_math-2.1.22.1.2
webview_flutter_android-2.8.82.8.8
webview_flutter_platform_interface-1.9.01.9.0
webview_flutter_wkwebview-2.7.52.7.5
win32-2.6.12.6.1
xdg_directories-0.2.0+10.2.0+1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.10` on webview_flutter does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions webview_flutter to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.12, Flutter 3.0.0, Dart 2.17.0.

15
likes
100
pub points
58%
popularity

Publisher

unverified uploader

A new Flutter plugin to create payment gateway using SafexPay

Homepage

Documentation

API reference

License

unknown (LICENSE)

Dependencies

connectivity, encrypt, flutter, http, modal_progress_hud_nsn, rxdart, shared_preferences, webview_flutter

More

Packages that depend on safexpay