place_picker 0.10.0 copy "place_picker: ^0.10.0" to clipboard
place_picker: ^0.10.0 copied to clipboard

Place picker fully written in dart for Flutter. Comes with autocomplete suggestions and nearby locations list. Localization too.

143
likes
80/ 160
pub points
96%
popularity

We analyzed this package 2 days ago, and awarded it 80 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

54 out of 119 API elements (45.4 %) have documentation comments.

Some symbols that are missing documentation: address_component, address_component.AddressComponent, address_component.AddressComponent.AddressComponent, address_component.AddressComponent.fromJson, address_component.AddressComponent.name.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:place_picker/place_picker.dart that imports:
  • package:google_maps_flutter/google_maps_flutter.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:place_picker/place_picker.dart that imports:
  • package:google_maps_flutter/google_maps_flutter.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:place_picker/place_picker.dart that imports:
  • package:google_maps_flutter/google_maps_flutter.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Web`.

Because:

  • package:place_picker/place_picker.dart that imports:
  • package:google_maps_flutter/google_maps_flutter.dart that imports:
  • package:google_maps_flutter_android/google_maps_flutter_android.dart that declares support for platforms: Android.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:place_picker/place_picker.dart that imports:
  • package:place_picker/widgets/widgets.dart that imports:
  • package:place_picker/widgets/place_picker.dart that imports:
  • package:geolocator/geolocator.dart that imports:
  • package:geolocator_apple/geolocator_apple.dart that declares support for platforms: iOS, macOS.
Package does not support platform `iOS`.

Because:

  • package:place_picker/place_picker.dart that imports:
  • package:google_maps_flutter/google_maps_flutter.dart that imports:
  • package:google_maps_flutter_android/google_maps_flutter_android.dart that declares support for platforms: Android.
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 15 issues. Showing the first 2:

ERROR: The getter 'bodyText1' isn't defined for the type 'TextTheme'.

lib/widgets/rich_suggestion.dart:35:89

   ╷
35 │       TextSpan(text: boldText, style: style.copyWith(color: Theme.of(context).textTheme.bodyText1?.color)),
   │                                                                                         ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/widgets/rich_suggestion.dart

ERROR: The getter 'bodyText1' isn't defined for the type 'TextTheme'.

lib/widgets/search_input.dart:60:65

   ╷
60 │           Icon(Icons.search, color: Theme.of(context).textTheme.bodyText1?.color),
   │                                                                 ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/widgets/search_input.dart

failed
Support up-to-date dependencies
10 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
geolocator ^9.0.1 9.0.2 12.0.0
google_maps_flutter ^2.2.0 2.7.0 2.7.0
http ^0.13.5 0.13.6 1.2.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
crypto - 3.0.3 3.0.3
csslib - 1.0.0 1.0.0
fixnum - 1.1.0 1.1.0
flutter_plugin_android_lifecycle - 2.0.20 2.0.20
flutter_web_plugins - 0.0.0 0.0.0
geolocator_android - 4.6.0 4.6.0
geolocator_apple - 2.3.7 2.3.7
geolocator_platform_interface - 4.2.3 4.2.3
geolocator_web - 2.2.1 4.0.0
geolocator_windows - 0.1.3 0.2.3
google_maps - 7.1.0 7.1.0
google_maps_flutter_android - 2.9.0 2.9.0
google_maps_flutter_ios - 2.7.0 2.7.0
google_maps_flutter_platform_interface - 2.7.1 2.7.1
google_maps_flutter_web - 0.5.8 0.5.8
html - 0.15.4 0.15.4
http_parser - 4.0.2 4.0.2
js - 0.6.7 0.7.1
js_wrapping - 0.7.4 0.7.4
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sanitize_html - 2.1.0 2.1.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
stream_transform - 2.1.0 2.1.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
uuid - 4.4.0 4.4.0
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^9.0.1` on geolocator does not support the stable version `10.0.0`.

Try running dart pub upgrade --major-versions geolocator to update the constraint.

The constraint `^0.13.5` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0/20 points: Compatible with dependency constraint lower bounds

downgrade analysis failed failed with 2 errors:

  • UNDEFINED_GETTER - lib/widgets/rich_suggestion.dart:35:89 - The getter 'bodyText1' isn't defined for the type 'TextTheme'.
  • UNDEFINED_GETTER - lib/widgets/search_input.dart:60:65 - The getter 'bodyText1' isn't defined for the type 'TextTheme'.

Run flutter pub downgrade and then flutter analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

143
likes
80
pub points
96%
popularity

Publisher

verified publisherdegreat.co.uk

Place picker fully written in dart for Flutter. Comes with autocomplete suggestions and nearby locations list. Localization too.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter, geolocator, google_maps_flutter, http

More

Packages that depend on place_picker