parse_server_sdk_flutter 8.0.0 copy "parse_server_sdk_flutter: ^8.0.0" to clipboard
parse_server_sdk_flutter: ^8.0.0 copied to clipboard

The Flutter SDK to connect to Parse Server. Build your apps faster with Parse Platform, the complete application stack.

128
likes
150/ 160
pub points
95%
popularity

We analyzed this package 2 days ago, and awarded it 150 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

262 out of 742 API elements (35.3 %) have documentation comments.

Some symbols that are missing documentation: flutter_parse_sdk_flutter, flutter_parse_sdk_flutter.CoreStore, flutter_parse_sdk_flutter.CoreStore.CoreStore, flutter_parse_sdk_flutter.CoreStore.clear, flutter_parse_sdk_flutter.CoreStore.containsKey.

10/10 points: Package has an example and has no issues with screenshots

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:parse_server_sdk_flutter/parse_server_sdk_flutter.dart that imports:
  • package:parse_server_sdk/parse_server_sdk.dart that imports:
  • package:parse_server_sdk/src/network/parse_http_client.dart that imports:
  • package:universal_io/io.dart that imports:
  • package:universal_io/src/_exports_in_browser.dart that imports:
  • package:universal_io/src/internet_address.dart that imports:
  • dart:io

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:parse_server_sdk_flutter/parse_server_sdk_flutter.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:parse_server_sdk_flutter/parse_server_sdk_flutter.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `Windows`.

Because:

  • package:parse_server_sdk_flutter/parse_server_sdk_flutter.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
Package does not support platform `Linux`.

Because:

  • package:parse_server_sdk_flutter/parse_server_sdk_flutter.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:parse_server_sdk_flutter/parse_server_sdk_flutter.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
connectivity_plus ^5.0.2 5.0.2 6.0.3
flutter flutter 0.0.0 0.0.0
package_info_plus ^4.2.0 4.2.0 8.0.0
parse_server_sdk ^6.4.0 6.4.0 7.0.0
path ^1.8.3 1.9.0 1.9.0
path_provider ^2.1.2 2.1.3 2.1.3
sembast ^3.6.0 3.7.1+2 3.7.1+2
sembast_web ^2.2.0 2.4.0+2 2.4.0+2
shared_preferences ^2.2.2 2.2.3 2.2.3
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
connectivity_plus_platform_interface - 1.2.4 2.0.0
cross_file - 0.3.4+1 0.3.4+1
crypto - 3.0.3 3.0.3
dbus - 0.7.10 0.7.10
dio - 5.4.3+1 5.4.3+1
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
flutter_web_plugins - 0.0.0 0.0.0
http - 0.13.6 1.2.1
http_parser - 4.0.2 4.1.0
idb_shim - 2.5.0+1 2.5.0+1
js - 0.6.7 0.7.1
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
mime - 1.0.5 1.0.5
nm - 0.5.0 0.5.0
package_info_plus_platform_interface - 2.0.1 3.0.0
path_provider_android - 2.2.6 2.2.6
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
petitparser - 6.0.2 6.0.2
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
shared_preferences_android - 2.2.3 2.2.3
shared_preferences_foundation - 2.4.0 2.4.0
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
timezone - 0.9.3 0.9.3
typed_data - 1.3.2 1.3.2
universal_io - 2.2.2 2.2.2
uuid - 3.0.7 4.4.0
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
web_socket_channel - 2.4.5 3.0.0
win32 - 5.5.1 5.5.1
xdg_directories - 1.0.4 1.0.4
xml - 6.5.0 6.5.0
xxtea - 2.1.0 2.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^5.0.2` on connectivity_plus does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions connectivity_plus to update the constraint.

The constraint `^4.2.0` on package_info_plus does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions package_info_plus to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.