ns_utils 0.0.4

Flutter Android iOS web

Set of methods/extentions for flutter that makes using framework in a much easier and clean way also adds additional functionality.

6
likes
100 / 110
pub points
74 %
popularity

We analyzed this package on Oct 22, 2020, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 91 out of 322 API elements (28.3 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:ns_utils/extensions/context.dart that imports:
  • package:ns_utils/utils/logs.dart that imports:
  • package:ns_utils/src.dart that imports:
  • package:ns_utils/services/shared_preferences/sp_service.dart that imports:
  • package:shared_preferences/shared_preferences.dart that declares support for platforms: Android, iOS, Linux, macOS, Web

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support Flutter platform Android

Because:

  • package:ns_utils/extensions/context.dart that imports:
  • package:ns_utils/utils/logs.dart that imports:
  • package:ns_utils/src.dart that imports:
  • package:ns_utils/services/shared_preferences/sp_service.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows
Package does not support Flutter platform iOS

Because:

  • package:ns_utils/extensions/context.dart that imports:
  • package:ns_utils/utils/logs.dart that imports:
  • package:ns_utils/src.dart that imports:
  • package:ns_utils/services/shared_preferences/sp_service.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows
Package does not support Flutter platform Linux

Because:

  • package:ns_utils/extensions/context.dart that imports:
  • package:ns_utils/utils/logs.dart that imports:
  • package:ns_utils/src.dart that imports:
  • package:ns_utils/services/shared_preferences/sp_service.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows
Package does not support Flutter platform macOS

Because:

  • package:ns_utils/extensions/context.dart that imports:
  • package:ns_utils/utils/logs.dart that imports:
  • package:ns_utils/src.dart that imports:
  • package:ns_utils/services/shared_preferences/sp_service.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows
Package does not support Flutter platform Web

Because:

  • package:ns_utils/extensions/context.dart that imports:
  • package:ns_utils/utils/logs.dart that imports:
  • package:ns_utils/src.dart that imports:
  • package:ns_utils/services/shared_preferences/sp_service.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
crossplat_objectid^2.1.42.1.42.1.4
flutterflutter0.0.00.0.0
flutter_screenutil^2.3.12.3.13.2.0
intl^0.16.10.16.10.16.1
shared_preferences^0.5.7+10.5.12+20.5.12+2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0-nullsafety.4
collection-1.15.0-nullsafety.31.15.0-nullsafety.3
ffi-0.1.30.1.3
file-5.2.15.2.1
flutter_web_plugins-0.0.00.0.0
meta-1.3.0-nullsafety.31.3.0-nullsafety.4
path-1.7.01.8.0-nullsafety.1
path_provider_linux-0.0.1+20.0.1+2
path_provider_platform_interface-1.0.31.0.3
path_provider_windows-0.0.4+10.0.4+1
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
process-3.0.133.0.13
shared_preferences_linux-0.0.2+20.0.2+2
shared_preferences_macos-0.0.1+100.0.1+10
shared_preferences_platform_interface-1.0.41.0.4
shared_preferences_web-0.1.2+70.1.2+7
shared_preferences_windows-0.0.1+10.0.1+1
sky_engine-0.0.990.0.99
typed_data-1.3.0-nullsafety.31.3.0-nullsafety.3
vector_math-2.1.0-nullsafety.32.1.0-nullsafety.3
win32-1.7.31.7.3
xdg_directories-0.1.20.1.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.3.1` on flutter_screenutil does not support the latest published version `3.2.0`

pubspec.yaml:14:23

   ╷
14 │   flutter_screenutil: ^2.3.1
   │                       ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

6
likes
100
pub points
74%
popularity

Publisher

dart.nonstopio.com

Set of methods/extentions for flutter that makes using framework in a much easier and clean way also adds additional functionality.

Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

MIT (LICENSE)

Dependencies

crossplat_objectid, flutter, flutter_screenutil, intl, shared_preferences

More

Packages that depend on ns_utils