ns_firebase_utils 0.0.3
ns_firebase_utils: ^0.0.3 copied to clipboard

Set of methods/extentions for firebase that makes using framework in a much easier and clean way also adds additional functionality

3
likes
70/ 130
pub points
29%
popularity

We analyzed this package on Oct 13, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 18 out of 98 API elements (18.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:ns_firebase_utils/storage/firebase_storage_service.dart that imports:
  • package:firebase_storage/firebase_storage.dart that imports:
  • package:firebase_storage_platform_interface/firebase_storage_platform_interface.dart that imports:
  • package:firebase_storage_platform_interface/src/platform_interface/platform_interface_reference.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run flutter pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
Because mockito >=4.0.0 <=4.1.1 depends on test_api ^0.2.1 and mockito >=4.1.1+1 <4.1.2 depends on test_api >=0.2.1 <0.4.0, mockito >=4.0.0 <4.1.2 requires test_api >=0.2.1 <0.4.0.
And because mockito >=4.1.2 <=5.0.0-nullsafety.7 depends on test_api ^0.2.19-nullsafety and every version of flutter_test from sdk depends on test_api 0.4.2, flutter_test from sdk is incompatible[...]
And because cloud_firestore_mocks 0.6.0 depends on mockito ^4.1.1 and no versions of cloud_firestore_mocks match >0.6.0 <0.7.0, flutter_test from sdk is incompatible with cloud_firestore_mocks ^0.6.0.
So, because ns_firebase_utils depends on both cloud_firestore_mocks ^0.6.0 and flutter_test any from sdk, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.