ns_firebase_utils 0.0.3
ns_firebase_utils: ^0.0.3 copied to clipboard

Set of methods/extentions for firebase that makes using framework in a much easier and clean way also adds additional functionality

Use this package as a library

Depend on it

Run this command:

With Flutter:

 $ flutter pub add ns_firebase_utils

This will add a line like this to your package's pubspec.yaml (and run an implicit flutter pub get):

dependencies:
  ns_firebase_utils: ^0.0.3

Alternatively, your editor might support or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:ns_firebase_utils/analytics/analytics_service.dart';
import 'package:ns_firebase_utils/api/firebase_api.dart';
import 'package:ns_firebase_utils/constants.dart';
import 'package:ns_firebase_utils/extentions/map.dart';
import 'package:ns_firebase_utils/reactive_widget/base_reactive_widget.dart';
import 'package:ns_firebase_utils/storage/firebase_storage_service.dart';
import 'package:ns_firebase_utils/utils/logs.dart';
import 'package:ns_firebase_utils/utils/nsf_exception.dart';
import 'package:ns_firebase_utils/utils/nsf_keys.dart';
import 'package:ns_firebase_utils/utils/nsf_strings.dart';