nhost_flutter_graphql 3.0.5 copy "nhost_flutter_graphql: ^3.0.5" to clipboard
nhost_flutter_graphql: ^3.0.5 copied to clipboard

Provides GraphQL clients to your Flutter application, automatically configured to work with Nhost

7
likes
140/ 140
pub points
73%
popularity

We analyzed this package 11 hours ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

94 out of 123 API elements (76.4 %) have documentation comments.

Some symbols that are missing documentation: nhost_flutter_graphql, nhost_flutter_graphql.ApiException.body, nhost_flutter_graphql.ApiException.request, nhost_flutter_graphql.ApiException.response, nhost_flutter_graphql.ApiException.responseBody.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:nhost_flutter_graphql/nhost_flutter_graphql.dart that imports:
  • package:nhost_flutter_graphql/src/graphql_provider.dart that imports:
  • package:graphql_flutter/graphql_flutter.dart that imports:
  • package:graphql_flutter/src/widgets/hooks/subscription.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
Package does not support platform `iOS`.

Because:

  • package:nhost_flutter_graphql/nhost_flutter_graphql.dart that imports:
  • package:nhost_flutter_graphql/src/graphql_provider.dart that imports:
  • package:graphql_flutter/graphql_flutter.dart that imports:
  • package:graphql_flutter/src/widgets/hooks/subscription.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
Package does not support platform `Windows`.

Because:

  • package:nhost_flutter_graphql/nhost_flutter_graphql.dart that imports:
  • package:nhost_flutter_graphql/src/graphql_provider.dart that imports:
  • package:graphql_flutter/graphql_flutter.dart that imports:
  • package:graphql_flutter/src/widgets/hooks/subscription.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
Package does not support platform `macOS`.

Because:

  • package:nhost_flutter_graphql/nhost_flutter_graphql.dart that imports:
  • package:nhost_flutter_graphql/src/graphql_provider.dart that imports:
  • package:graphql_flutter/graphql_flutter.dart that imports:
  • package:graphql_flutter/src/widgets/hooks/subscription.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
Package does not support platform `Web`.

Because:

  • package:nhost_flutter_graphql/nhost_flutter_graphql.dart that imports:
  • package:nhost_flutter_graphql/src/graphql_provider.dart that imports:
  • package:graphql_flutter/graphql_flutter.dart that imports:
  • package:graphql_flutter/src/hive_init.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
graphql_flutter ^5.1.0 5.2.0-beta.6 5.2.0-beta.6
logging ^1.1.0 1.2.0 1.2.0
nhost_flutter_auth ^4.0.4 4.0.4 4.0.4
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
connectivity_plus - 5.0.2 6.0.2
connectivity_plus_platform_interface - 1.2.4 2.0.0
crypto - 3.0.3 3.0.3
dbus - 0.7.10 0.7.10
ffi - 2.1.2 2.1.2
fixnum - 1.1.0 1.1.0
flutter_hooks - 0.20.5 0.20.5
flutter_web_plugins - 0.0.0 0.0.0
gql - 1.0.1-alpha+1709845491443 1.0.1-alpha+1709845491443
gql_dedupe_link - 2.0.4-alpha+1709845491527 2.0.4-alpha+1709845491527
gql_error_link - 1.0.0+1 1.0.0+1
gql_exec - 1.1.1-alpha+1699813812660 1.1.1-alpha+1699813812660
gql_http_link - 1.0.1+1 1.0.1+1
gql_link - 1.0.1-alpha+1709845491457 1.0.1-alpha+1709845491457
gql_transform_link - 1.0.0 1.0.0
gql_websocket_link - 2.0.1 2.0.1
graphql - 5.2.0-beta.7 5.2.0-beta.7
hive - 2.2.3 2.2.3
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
js - 0.6.7 0.7.1
jwt_decoder - 2.0.1 2.0.1
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
nhost_auth_dart - 2.2.0 2.2.0
nhost_dart - 2.0.4 2.0.4
nhost_functions_dart - 2.0.4 2.0.4
nhost_gql_links - 4.0.5 4.0.5
nhost_graphql_adapter - 4.0.4 4.0.4
nhost_sdk - 5.3.0 5.3.0
nhost_storage_dart - 2.0.4 2.0.4
nm - 0.5.0 0.5.0
normalize - 0.8.2+1 0.9.1
path - 1.9.0 1.9.0
path_provider - 2.1.3 2.1.3
path_provider_android - 2.2.4 2.2.4
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
petitparser - 6.0.2 6.0.2
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
rxdart - 0.27.7 0.27.7
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
uuid - 4.4.0 4.4.0
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
web_socket_channel - 2.4.5 2.4.5
win32 - 5.4.0 5.4.0
xdg_directories - 1.0.4 1.0.4
xml - 6.5.0 6.5.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

7
likes
140
pub points
73%
popularity

Publisher

verified publishernhost.io

Provides GraphQL clients to your Flutter application, automatically configured to work with Nhost

Homepage
Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, graphql_flutter, logging, nhost_flutter_auth

More

Packages that depend on nhost_flutter_graphql