ngdart 7.1.1 copy "ngdart: ^7.1.1" to clipboard
ngdart: ^7.1.1 copied to clipboard

Platformweb

Fast and productive web framework by Google. Separate, but similar to the JavaScript framework with a similar name.

36
likes
120/ 160
pub points
91%
popularity

We analyzed this package 2 days ago, and awarded it 120 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

260 out of 321 API elements (81.0 %) have documentation comments.

Some symbols that are missing documentation: angular.AfterChanges.ngAfterChanges, angular.AfterContentChecked.ngAfterContentChecked, angular.AfterContentInit.ngAfterContentInit, angular.AfterViewChecked.ngAfterViewChecked, angular.AfterViewInit.ngAfterViewInit.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Web

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:ngdart/angular.dart that imports:
  • package:ngdart/src/testability.dart that imports:
  • package:ngdart/src/testability/testability.dart that imports:
  • package:ngdart/src/testability/js_api.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform iOS

Because:

  • package:ngdart/angular.dart that imports:
  • package:ngdart/src/testability.dart that imports:
  • package:ngdart/src/testability/testability.dart that imports:
  • package:ngdart/src/testability/js_api.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform Windows

Because:

  • package:ngdart/angular.dart that imports:
  • package:ngdart/src/testability.dart that imports:
  • package:ngdart/src/testability/testability.dart that imports:
  • package:ngdart/src/testability/js_api.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform Linux

Because:

  • package:ngdart/angular.dart that imports:
  • package:ngdart/src/testability.dart that imports:
  • package:ngdart/src/testability/testability.dart that imports:
  • package:ngdart/src/testability/js_api.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform macOS

Because:

  • package:ngdart/angular.dart that imports:
  • package:ngdart/src/testability.dart that imports:
  • package:ngdart/src/testability/testability.dart that imports:
  • package:ngdart/src/testability/js_api.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 39 issues. Showing the first 2:

INFO: 'bootstrapStatic' is deprecated and shouldn't be used. Renamed "runAppLegacy". See "runApp" for the preferred API.

lib/angular.dart:21:64

   ╷
21 │     show runApp, runAppAsync, runAppLegacy, runAppLegacyAsync, bootstrapStatic;
   │                                                                ^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/angular.dart

INFO: Dangling library doc comment.

lib/di.dart:1:1

  ╷
1 │ /// NOTE: As of 2020-08-12, this library is DEPRECATED.
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/di.dart

failed
Support up-to-date dependencies
10 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
build ^2.0.0 2.4.1 2.4.1
build_config ^1.0.0 1.1.1 1.1.1
built_collection ^5.0.0 5.1.1 5.1.1
built_value ^8.0.0 8.9.2 8.9.2
code_builder ^4.0.0 4.10.0 4.10.0
collection ^1.15.0 1.19.0 1.19.0
csslib ^0.17.0 0.17.3 1.0.0
intl ^0.17.0 0.17.0 0.19.0
js ^0.6.3 0.6.7 0.7.1
logging ^1.0.0 1.2.0 1.2.0
meta ^1.3.0 1.15.0 1.15.0
ngast ^2.1.4 2.1.4 2.1.4
ngcompiler ^2.1.2 2.1.3 2.1.3
path ^1.8.0 1.9.0 1.9.0
quiver ^3.0.0 3.2.1 3.2.1
source_gen ^1.0.0 1.2.6 1.5.0
source_span ^1.8.0 1.10.0 1.10.0
stack_trace ^1.10.0 1.11.1 1.11.1
stream_transform ^2.0.0 2.1.0 2.1.0
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 47.0.0 72.0.0
analyzer - 4.7.0 6.7.0
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
build_resolvers - 2.0.10 2.4.2
build_test - 2.2.0 2.2.2
charcode - 1.3.1 1.3.1
checked_yaml - 2.0.3 2.0.3
clock - 1.1.1 1.1.1
convert - 3.1.1 3.1.1
coverage - 1.6.4 1.8.0
crypto - 3.0.3 3.0.3
dart_style - 2.2.4 2.3.6
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
frontend_server_client - 3.2.0 4.0.0
glob - 2.1.2 2.1.2
graphs - 2.3.1 2.3.1
html - 0.15.4 0.15.4
http_multi_server - 3.2.1 3.2.1
http_parser - 4.1.0 4.1.0
io - 1.0.4 1.0.4
json_annotation - 4.9.0 4.9.0
matcher - 0.12.16+1 0.12.16+1
mime - 1.0.5 1.0.5
node_preamble - 2.0.2 2.0.2
package_config - 2.1.0 2.1.0
pool - 1.5.1 1.5.1
pub_semver - 2.1.4 2.1.4
pubspec_parse - 1.3.0 1.3.0
shelf - 1.4.2 1.4.2
shelf_packages_handler - 3.0.2 3.0.2
shelf_static - 1.1.2 1.1.2
shelf_web_socket - 1.0.4 2.0.0
source_map_stack_trace - 2.1.1 2.1.1
source_maps - 0.10.12 0.10.12
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test - 1.24.3 1.25.7
test_api - 0.6.0 0.7.2
test_core - 0.5.3 0.6.4
typed_data - 1.3.2 1.3.2
vm_service - 11.10.0 14.2.4
watcher - 1.1.0 1.1.0
web - 0.5.1 0.5.1
web_socket_channel - 2.4.5 3.0.0
webkit_inspection_protocol - 1.2.1 1.2.1
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.17.0` on csslib does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions csslib to update the constraint.

The constraint `^0.17.0` on intl does not support the stable version `0.18.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0/20 points: Compatible with dependency constraint lower bounds

downgrade analysis failed failed with 8 errors:

  • UNDEFINED_ANNOTATION - lib/src/devtools/model.dart:61:3 - Undefined name 'BuiltValueHook' used as an annotation.
  • INVALID_OVERRIDE - lib/src/devtools/model.g.dart:31:21 - '_$InspectorNodeSerializer.serialize' ('Iterable<Object?> Function(Serializers, InspectorNode, {FullType specifiedType})') isn't a valid override of 'StructuredSerializer.serialize' ('Iterable

Analyzed with Pana 0.22.7, Dart 3.4.3.

Check the analysis log for details.

36
likes
120
pub points
91%
popularity

Publisher

verified publisherangulardart.xyz

Fast and productive web framework by Google. Separate, but similar to the JavaScript framework with a similar name.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

build, build_config, built_collection, built_value, code_builder, collection, csslib, intl, js, logging, meta, ngast, ngcompiler, path, quiver, source_gen, source_span, stack_trace, stream_transform

More

Packages that depend on ngdart