mega_cli 1.0.4 copy "mega_cli: ^1.0.4" to clipboard
mega_cli: ^1.0.4 copied to clipboard

A tool created for Megaleios developers, to help in their day to day work with flutter.

2
likes
120/ 140
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

33 out of 151 API elements (21.9 %) have documentation comments.

Some symbols that are missing documentation: android_create, android_create.AndroidCreate, android_create.AndroidCreate.AndroidCreate, android_create.AndroidCreate.init, base_conf.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ansicolor ^2.0.1 2.0.2 2.0.2
bosun ^0.2.2 0.2.2 0.2.2
dart_style ^2.3.2 2.3.2 2.3.6
dcli ^2.3.0 2.3.0 4.0.0
recase ^4.1.0 4.1.0 4.1.0
xml ^6.3.0 6.5.0 6.5.0
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 61.0.0 68.0.0
analyzer - 5.13.0 6.5.0
archive - 3.5.1 3.5.1
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
basic_utils - 5.5.4 5.7.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
charcode - 1.3.1 1.3.1
chunked_stream - 1.4.2 1.4.2
circular_buffer - 0.11.0 0.11.0
cli_util - 0.4.1 0.4.1
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
coverage - 1.6.4 1.8.0
crypto - 3.0.3 3.0.3
csv - 5.1.1 6.0.0
dart_console2 - 3.1.1 3.1.1
dcli_core - 2.3.0 4.0.0
equatable - 2.0.5 2.0.5
ffi - 2.1.2 2.1.2
file - 6.1.4 7.0.0
frontend_server_client - 3.2.0 4.0.0
functional_data - 1.2.0 1.2.0
glob - 2.1.2 2.1.2
globbing - 1.0.0 1.0.0
http - 0.13.6 1.2.1
http_multi_server - 3.2.1 3.2.1
http_parser - 4.0.2 4.0.2
ini - 2.1.0 2.1.0
intl - 0.18.1 0.19.0
io - 1.0.4 1.0.4
js - 0.6.7 0.7.1
json2yaml - 3.0.1 3.0.1
json_annotation - 4.9.0 4.9.0
logging - 1.2.0 1.2.0
matcher - 0.12.16+1 0.12.16+1
meta - 1.15.0 1.15.0
mime - 1.0.5 1.0.5
node_preamble - 2.0.2 2.0.2
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
petitparser - 6.0.2 6.0.2
pointycastle - 3.9.1 3.9.1
pool - 1.5.1 1.5.1
posix - 5.0.0 6.0.1
pub_semver - 2.1.4 2.1.4
pubspec2 - 2.4.2 4.0.0
pubspec_lock - 3.0.2 3.0.2
quiver - 3.2.1 3.2.1
random_string - 2.3.1 2.3.1
scope - 3.0.0 4.1.0
settings_yaml - 6.0.0 8.0.1
shelf - 1.4.1 1.4.1
shelf_packages_handler - 3.0.2 3.0.2
shelf_static - 1.1.2 1.1.2
shelf_web_socket - 1.0.4 2.0.0
source_map_stack_trace - 2.1.1 2.1.1
source_maps - 0.10.12 0.10.12
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
sum_types - 0.3.5 0.3.5
system_info2 - 4.0.0 4.0.0
term_glyph - 1.2.1 1.2.1
test_api - 0.6.1 0.7.1
test_core - 0.5.9 0.6.2
tree_iterator - 2.0.0 3.0.0
typed_data - 1.3.2 1.3.2
uri - 1.0.0 1.0.0
uuid - 3.0.7 4.4.0
validators2 - 5.0.0 5.0.0
vm_service - 11.10.0 14.2.2
watcher - 1.1.0 1.1.0
web - 0.5.1 0.5.1
web_socket_channel - 2.4.5 3.0.0
webkit_inspection_protocol - 1.2.1 1.2.1
win32 - 4.1.4 5.5.1
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.3.0` on dcli does not support the stable version `3.0.1`.

Try running dart pub upgrade --major-versions dcli to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

2
likes
120
pub points
0%
popularity

Publisher

unverified uploader

A tool created for Megaleios developers, to help in their day to day work with flutter.

Homepage

Documentation

API reference

License

MIT (LICENSE)

Dependencies

ansicolor, bosun, dart_style, dcli, recase, xml

More

Packages that depend on mega_cli