mediasoup_client_flutter 0.4.6
mediasoup_client_flutter: ^0.4.6 copied to clipboard

Mediasoup client side Flutter library. Work for Android, iOS, MacOS and browser.

19
likes
100/ 130
pub points
71%
popularity

We analyzed this package on Nov 25, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 152 out of 541 API elements (28.1 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:mediasoup_client_flutter/mediasoup_client_flutter.dart that imports:
  • package:mediasoup_client_flutter/src/rtp_parameters.dart that imports:
  • package:flutter_webrtc/flutter_webrtc.dart that declares support for platforms: Android, iOS, Windows, macOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 17 issues. Showing the first 2:

lib/mediasoup_client_flutter.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/Errors.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.15.01.15.01.15.0
events2^1.0.01.0.01.0.0
flutterflutter0.0.00.0.0
flutter_webrtc^0.6.70.6.10+hotfix.10.7.1
h264_profile_level_id^0.2.00.2.00.2.0
sdp_transform^0.3.00.3.20.3.2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
ffi-1.1.21.1.2
file-6.1.26.1.2
meta-1.7.01.7.0
path-1.8.01.8.0
path_provider-2.0.72.0.7
path_provider_android-2.0.92.0.9
path_provider_ios-2.0.72.0.7
path_provider_linux-2.1.22.1.2
path_provider_macos-2.0.32.0.3
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.42.0.4
platform-3.0.23.0.2
plugin_platform_interface-2.0.22.0.2
process-4.2.44.2.4
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
win32-2.3.12.3.1
xdg_directories-0.2.00.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.6.7` on flutter_webrtc does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions flutter_webrtc to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

19
likes
100
pub points
71%
popularity

Mediasoup client side Flutter library. Work for Android, iOS, MacOS and browser.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

collection, events2, flutter, flutter_webrtc, h264_profile_level_id, sdp_transform

More

Packages that depend on mediasoup_client_flutter