light_html_editor 0.4.3 copy "light_html_editor: ^0.4.3" to clipboard
light_html_editor: ^0.4.3 copied to clipboard

A lightweight HTML editor for Flutter. Provides functionality to edit and parse simple HTML code.

11
likes
130/ 140
pub points
77%
popularity

We analyzed this package 4 hours ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

155 out of 403 API elements (38.5 %) have documentation comments.

Some symbols that are missing documentation: background_color_button, button_row, button_row.ButtonRow.additionalButtons, button_row.ButtonRow.availableButtons, button_row.ButtonRow.availableColors.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 37 issues. Showing the first 2:

INFO: Statements in an if should be enclosed in a block.

lib/api/operations/tag_operation.dart:25:7

   ╷
25 │       throw Exception("No selection was applied to this TagOperation!");
   │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/api/operations/tag_operation.dart

INFO: Statements in an if should be enclosed in a block.

lib/api/operations/tag_operation.dart:39:11

   ╷
39 │           after = "$startTag$endTag$before";
   │           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/api/operations/tag_operation.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_html ^3.0.0-beta.2 3.0.0-beta.2 3.0.0-beta.2
google_fonts ^6.1.0 6.1.0 6.1.0
url_launcher ^6.2.2 6.2.4 6.2.4
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
csslib - 0.17.3 1.0.0
ffi - 2.1.2 2.1.2
flutter_web_plugins - 0.0.0 0.0.0
html - 0.15.4 0.15.4
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
list_counter - 1.0.2 1.0.2
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
path - 1.9.0 1.9.0
path_provider - 2.1.2 2.1.2
path_provider_android - 2.2.2 2.2.2
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
url_launcher_android - 6.3.0 6.3.0
url_launcher_ios - 6.2.4 6.2.4
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.1.0 3.1.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.0 2.3.0
url_launcher_windows - 3.1.1 3.1.1
vector_math - 2.1.4 2.1.4
web - 0.5.0 0.5.0
win32 - 5.2.0 5.2.0
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.0, Flutter 3.19.0, Dart 3.3.0.

Check the analysis log for details.

11
likes
130
pub points
77%
popularity

Publisher

verified publishermanuelh.at

A lightweight HTML editor for Flutter. Provides functionality to edit and parse simple HTML code.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, flutter_html, google_fonts, url_launcher

More

Packages that depend on light_html_editor