laoocr 0.0.9 copy "laoocr: ^0.0.9" to clipboard
laoocr: ^0.0.9 copied to clipboard

Lao OCR Scanner (Lao ID Card, Passport, etc...) and Face Liveliness.

14
likes
140/ 160
pub points
6%
popularity

We analyzed this package 3 days ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

9 out of 101 API elements (8.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: border_type, border_type.MaskForCameraViewBorderType, border_type.MaskForCameraViewBorderType.MaskForCameraViewBorderType, camera_description, camera_description.MaskForCameraViewCameraDescription.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:laoocr/laoocr.dart that imports:
  • package:laoocr/lao_ocr/mask_camera.dart that imports:
  • package:laoocr/lao_ocr/main_crop.dart that imports:
  • package:camera/camera.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:laoocr/laoocr.dart that imports:
  • package:laoocr/lao_ocr/mask_camera.dart that imports:
  • package:laoocr/lao_ocr/main_crop.dart that imports:
  • package:camera/camera.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:laoocr/laoocr.dart that imports:
  • package:laoocr/lao_ocr/mask_camera.dart that imports:
  • package:laoocr/lao_ocr/main_crop.dart that imports:
  • package:camera/camera.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Web`.

Because:

  • package:laoocr/laoocr.dart that imports:
  • package:laoocr/lao_ocr/mask_camera.dart that imports:
  • package:laoocr/lao_ocr/liveliness_face.dart that imports:
  • package:flutter_face_api/face_api.dart that declares support for platforms: Android, iOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
camera ^0.10.0+4 0.10.6 0.11.0+1
dotted_border ^2.0.0+3 2.1.0 2.1.0
flutter flutter 0.0.0 0.0.0
flutter_face_api ^4.1.1 4.1.1 6.2.1
google_ml_kit ^0.13.0 0.13.0 0.18.0
image ^4.0.15 4.2.0 4.2.0
path ^1.8.1 1.9.0 1.9.0
path_provider ^2.0.11 2.1.3 2.1.3
Transitive dependencies
Package Constraint Compatible Latest
archive - 3.6.1 3.6.1
camera_android - 0.10.9+6 0.10.9+6
camera_avfoundation - 0.9.16 0.9.16
camera_platform_interface - 2.7.4 2.7.4
camera_web - 0.3.3 0.3.3
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
cross_file - 0.3.4+1 0.3.4+1
crypto - 3.0.3 3.0.3
ffi - 2.1.2 2.1.2
flutter_plugin_android_lifecycle - 2.0.20 2.0.20
flutter_web_plugins - 0.0.0 0.0.0
google_mlkit_barcode_scanning - 0.5.0 0.12.0
google_mlkit_commons - 0.2.0 0.7.1
google_mlkit_digital_ink_recognition - 0.6.0 0.12.0
google_mlkit_entity_extraction - 0.6.0 0.13.0
google_mlkit_face_detection - 0.5.0 0.11.0
google_mlkit_image_labeling - 0.5.0 0.12.0
google_mlkit_language_id - 0.5.0 0.11.0
google_mlkit_object_detection - 0.6.0 0.13.0
google_mlkit_pose_detection - 0.5.0 0.12.0
google_mlkit_selfie_segmentation - 0.2.0 0.8.0
google_mlkit_smart_reply - 0.5.0 0.11.0
google_mlkit_text_recognition - 0.5.0 0.13.0
google_mlkit_translation - 0.5.0 0.11.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path_drawing - 1.0.1 1.0.1
path_parsing - 1.0.1 1.0.1
path_provider_android - 2.2.6 2.2.6
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
petitparser - 6.0.2 6.0.2
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
stream_transform - 2.1.0 2.1.0
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
win32 - 5.5.1 5.5.1
xdg_directories - 1.0.4 1.0.4
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.10.0+4` on camera does not support the stable version `0.11.0`.

Try running dart pub upgrade --major-versions camera to update the constraint.

The constraint `^4.1.1` on flutter_face_api does not support the stable version `5.1.0`.

Try running dart pub upgrade --major-versions flutter_face_api to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

14
likes
140
pub points
6%
popularity

Publisher

unverified uploader

Lao OCR Scanner (Lao ID Card, Passport, etc...) and Face Liveliness.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

camera, dotted_border, flutter, flutter_face_api, google_ml_kit, image, path, path_provider

More

Packages that depend on laoocr