gits_cli 2.2.0 copy "gits_cli: ^2.2.0" to clipboard
gits_cli: ^2.2.0 copied to clipboard

Get it simple command flutter with Gits CLI

11
likes
130/ 160
pub points
20%
popularity

We analyzed this package 7 hours ago, and awarded it 130 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

965 out of 1235 API elements (78.1 %) have documentation comments.

Some symbols that are missing documentation: analyze_command, analyze_command.AnalyzeCommand, analyze_command.AnalyzeCommand.AnalyzeCommand, apk_command, apk_command.ApkCommand.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:gits_cli/build_app/apk/apk_command.dart that imports:
  • package:gits_cli/helper/helper.dart that imports:
  • package:gits_cli/helper/yaml_helper.dart that imports:
  • package:gits_cli/helper/status_helper.dart that imports:
  • package:gits_cli/dependency_manager.dart that imports:
  • package:dcli/dcli.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `iOS`.

Because:

  • package:gits_cli/build_app/apk/apk_command.dart that imports:
  • package:gits_cli/helper/helper.dart that imports:
  • package:gits_cli/helper/yaml_helper.dart that imports:
  • package:gits_cli/helper/status_helper.dart that imports:
  • package:gits_cli/dependency_manager.dart that imports:
  • package:dcli/dcli.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `Web`.

Because:

  • package:gits_cli/build_app/apk/apk_command.dart that imports:
  • package:gits_cli/helper/helper.dart that imports:
  • package:gits_cli/helper/yaml_helper.dart that imports:
  • package:gits_cli/helper/status_helper.dart that imports:
  • package:gits_cli/dependency_manager.dart that imports:
  • package:dcli/dcli.dart that declares support for platforms: Windows, Linux, macOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Linux`.

Because:

  • package:gits_cli/build_app/apk/apk_command.dart that imports:
  • package:gits_cli/helper/helper.dart that imports:
  • package:gits_cli/helper/yaml_helper.dart that imports:
  • package:gits_cli/helper/status_helper.dart that imports:
  • package:gits_cli/dependency_manager.dart that imports:
  • package:dcli/dcli.dart that imports:
  • package:dcli/src/util/terminal.dart that imports:
  • package:dart_console2/dart_console2.dart that imports:
  • package:dart_console2/src/console.dart that imports:
  • package:dart_console2/src/ffi/win/termlib_win.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:gits_cli/build_app/apk/apk_command.dart that imports:
  • package:gits_cli/helper/helper.dart that imports:
  • package:gits_cli/helper/yaml_helper.dart that imports:
  • package:gits_cli/helper/status_helper.dart that imports:
  • package:gits_cli/dependency_manager.dart that imports:
  • package:dcli/dcli.dart that imports:
  • package:dcli/src/util/terminal.dart that imports:
  • package:dart_console2/dart_console2.dart that imports:
  • package:dart_console2/src/console.dart that imports:
  • package:dart_console2/src/ffi/win/termlib_win.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
args ^2.4.2 2.5.0 2.5.0
collection ^1.17.1 1.19.0 1.19.0
dcli ^2.2.3 2.3.0 4.0.1
path ^1.8.3 1.9.0 1.9.0
path_to_regexp ^0.4.0 0.4.0 0.4.0
yaml ^3.1.2 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 61.0.0 70.0.0
analyzer - 5.13.0 6.6.0
archive - 3.6.1 3.6.1
async - 2.11.0 2.11.0
basic_utils - 5.5.4 5.7.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
charcode - 1.3.1 1.3.1
chunked_stream - 1.4.2 1.4.2
circular_buffer - 0.11.0 0.11.0
cli_util - 0.4.1 0.4.1
clock - 1.1.1 1.1.1
convert - 3.1.1 3.1.1
coverage - 1.6.4 1.8.0
crypto - 3.0.3 3.0.3
csv - 5.1.1 6.0.0
dart_console2 - 3.1.1 3.1.1
dcli_core - 2.3.0 4.0.0
equatable - 2.0.5 2.0.5
ffi - 2.1.2 2.1.2
file - 6.1.4 7.0.0
frontend_server_client - 3.2.0 4.0.0
functional_data - 1.2.0 1.2.0
glob - 2.1.2 2.1.2
globbing - 1.0.0 1.0.0
http - 0.13.6 1.2.1
http_multi_server - 3.2.1 3.2.1
http_parser - 4.0.2 4.0.2
ini - 2.1.0 2.1.0
intl - 0.18.1 0.19.0
io - 1.0.4 1.0.4
js - 0.6.7 0.7.1
json2yaml - 3.0.1 3.0.1
json_annotation - 4.9.0 4.9.0
logging - 1.2.0 1.2.0
matcher - 0.12.16+1 0.12.16+1
meta - 1.15.0 1.15.0
mime - 1.0.5 1.0.5
node_preamble - 2.0.2 2.0.2
package_config - 2.1.0 2.1.0
pointycastle - 3.9.1 3.9.1
pool - 1.5.1 1.5.1
posix - 5.0.0 6.0.1
pub_semver - 2.1.4 2.1.4
pubspec2 - 2.4.2 4.0.0
pubspec_lock - 3.0.2 3.0.2
quiver - 3.2.1 3.2.1
random_string - 2.3.1 2.3.1
scope - 3.0.0 4.1.0
settings_yaml - 6.0.0 8.1.0
shelf - 1.4.1 1.4.1
shelf_packages_handler - 3.0.2 3.0.2
shelf_static - 1.1.2 1.1.2
shelf_web_socket - 1.0.4 2.0.0
source_map_stack_trace - 2.1.1 2.1.1
source_maps - 0.10.12 0.10.12
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
sum_types - 0.3.5 0.3.5
system_info2 - 4.0.0 4.0.0
term_glyph - 1.2.1 1.2.1
test_api - 0.6.1 0.7.2
test_core - 0.5.9 0.6.4
typed_data - 1.3.2 1.3.2
uri - 1.0.0 1.0.0
uuid - 3.0.7 4.4.0
validators2 - 5.0.0 5.0.0
vm_service - 11.10.0 14.2.4
watcher - 1.1.0 1.1.0
web - 0.5.1 0.5.1
web_socket_channel - 2.4.5 3.0.0
webkit_inspection_protocol - 1.2.1 1.2.1
win32 - 4.1.4 5.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.2.3` on dcli does not support the stable version `3.0.1`.

Try running dart pub upgrade --major-versions dcli to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.

11
likes
130
pub points
20%
popularity

Publisher

verified publishergits.id

Get it simple command flutter with Gits CLI

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

args, collection, dcli, path, path_to_regexp, yaml

More

Packages that depend on gits_cli