fvm 2.3.1 icon indicating copy to clipboard operation
fvm: ^2.3.1 copied to clipboard

A simple cli to manage Flutter SDK versions per project. Support channels, releases, and local cache for fast switching between versions.

368
likes
130/ 130
pub points
88%
popularity

We analyzed this package 12 hours ago, and awarded it 130 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 127 out of 132 API elements (96.2 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:fvm/fvm.dart that imports:
  • package:fvm/src/utils/fvm_client.dart that imports:
  • package:fvm/src/utils/logger.dart that imports:
  • package:io/ansi.dart that imports:
  • package:io/src/ansi_code.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^2.1.02.3.12.3.1
cli_notify^0.0.30.0.30.0.3
cli_util^0.3.50.3.50.3.5
console^4.1.04.1.04.1.0
date_format^2.0.22.0.62.0.6
io^1.0.01.0.31.0.3
meta^1.3.01.8.01.8.0
path^1.8.01.8.21.8.2
process_run^0.12.10.12.3+20.12.3+2
yaml^3.1.03.1.13.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.16.01.16.0
pub_semver-2.1.12.1.1
source_span-1.9.01.9.0
string_scanner-1.1.11.1.1
synchronized-3.0.0+23.0.0+2
term_glyph-1.2.11.2.1
tint-2.0.02.0.0
vector_math-2.1.22.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.13, Dart 2.17.5.

368
likes
130
pub points
88%
popularity

Publisher

verified publisher iconfvm.app

A simple cli to manage Flutter SDK versions per project. Support channels, releases, and local cache for fast switching between versions.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

args, cli_notify, cli_util, console, date_format, io, meta, path, process_run, yaml

More

Packages that depend on fvm