fo_components 1.10.4+2

Dart js
Flutter web

A collection of Angular components for both common and less common use cases.

1
likes
70 / 110
pub points
59 %
popularity

We analyzed this package on Sep 25, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

0/10 points: 20% or more of the public API has dartdoc comments

  • 101 out of 901 API elements (11.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:fo_components/fo_components.dart that imports:
  • package:fo_components/validators/fo_validators.dart that imports:
  • package:angular_forms/angular_forms.dart that imports:
  • package:angular_forms/src/validators.dart that imports:
  • package:angular_forms/src/model.dart that imports:
  • package:angular_forms/src/directives/validators.dart that imports:
  • package:angular/angular.dart that imports:
  • package:angular/src/platform/browser/tools/tools.dart that imports:
  • package:angular/src/platform/browser/tools/common_tools.dart that imports:
  • package:angular/src/core/linker/component_factory.dart that imports:
  • package:angular/src/core/linker/views/host_view.dart that imports:
  • package:angular/src/core/linker/views/dynamic_view.dart that imports:
  • package:angular/src/core/linker/view_ref.dart that imports:
  • dart:html
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 28 issues. Showing the first 2:

INFO: DO use curly braces for all flow control structures.

lib/components/fo_data_table/fo_data_table_component.dart:214:7

    ╷
214 │ ┌       selectedRows = filteredKeys
215 │ │           .where((o) => errorFunction == null || errorFunction(data[o]) == null)
216 │ └           .toSet();
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/components/fo_data_table/fo_data_table_component.dart

INFO: DO use curly braces for all flow control structures.

lib/components/fo_data_table/fo_data_table_component.dart:218:7

    ╷
218 │       selectedRows.clear();
    │       ^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/components/fo_data_table/fo_data_table_component.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angular^6.0.0-alpha6.0.0-alpha+15.3.1
angular_components^0.14.0-alpha0.14.0-alpha+10.13.0+1
angular_forms^2.1.32.1.42.1.4
collection^1.14.111.14.131.14.13
grid_css^2.0.02.0.12.0.1
intl^0.15.80.15.80.16.1
json_annotation^3.0.03.1.03.1.0
sass_builder^2.1.32.1.32.1.3
Transitive dependencies
PackageConstraintCompatibleLatest
analyzer-0.37.1+10.40.3
angular_ast-0.5.110.5.11
angular_compiler-0.4.50.4.5
args-1.6.01.6.0
async-2.4.22.4.2
build-1.5.01.5.0
build_config-0.4.20.4.2
built_collection-4.3.24.3.2
built_value-7.1.07.1.0
charcode-1.1.31.1.3
checked_yaml-1.0.21.0.2
cli_repl-0.2.0+10.2.0+1
code_builder-3.4.13.4.1
convert-2.1.12.1.1
crypto-2.1.52.1.5
csslib-0.16.20.16.2
dart_internal-0.1.100.1.10
dart_style-1.2.101.3.7
fixnum-0.10.110.10.11
front_end-0.1.21+10.1.29
glob-1.2.01.2.0
html-0.14.0+30.14.0+3
http-0.12.20.12.2
http_parser-3.1.43.1.4
js-0.6.20.6.2
kernel-0.3.21+10.3.29
logging-0.11.40.11.4
matcher-0.12.90.12.9
meta-1.2.31.2.3
node_interop-1.1.11.1.1
node_io-1.1.11.1.1
observable-0.22.20.22.2
package_config-1.9.31.9.3
package_resolver-1.0.101.0.10
path-1.7.01.7.0
pedantic-1.9.21.9.2
protobuf-0.13.16+11.0.1
pub_semver-1.4.41.4.4
pubspec_parse-0.1.50.1.5
quiver-2.1.32.1.3
sass-1.26.111.26.11
source_gen-0.9.4+60.9.7+1
source_maps-0.10.90.10.9
source_span-1.7.01.7.0
stack_trace-1.9.51.9.5
stream_transform-1.2.01.2.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
tuple-1.0.31.0.3
typed_data-1.2.01.2.0
watcher-0.9.7+150.9.7+15
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^6.0.0-alpha` on angular does not support the latest published version `5.3.1`

pubspec.yaml:9:12

  ╷
9 │   angular: ^6.0.0-alpha
  │            ^^^^^^^^^^^^
  ╵
The constraint `^0.14.0-alpha` on angular_components does not support the latest published version `0.13.0+1`

pubspec.yaml:10:23

   ╷
10 │   angular_components: ^0.14.0-alpha
   │                       ^^^^^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

1
likes
70
pub points
59%
popularity

A collection of Angular components for both common and less common use cases.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

patrick.minogue@gmail.com

License

MIT (LICENSE)

Dependencies

angular, angular_components, angular_forms, collection, grid_css, intl, json_annotation, sass_builder

More

Packages that depend on fo_components