flutter_vasat 0.1.4 copy "flutter_vasat: ^0.1.4" to clipboard
flutter_vasat: ^0.1.4 copied to clipboard

Vasat SDK for flutter apps.

1
likes
40/ 140
pub points
0%
popularity

We analyzed this package 19 hours ago, and awarded it 40 pub points (of a possible 140):

failed
Follow Dart file conventions
10 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

11 out of 187 API elements (5.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: device, device.Device, device.Device.Device, device.Device.allowPush, device.Device.crs.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Web`.

Because:

  • package:flutter_vasat/models/device.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus_windows/device_info_plus_windows.dart that declares support for platforms: Windows.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:flutter_vasat/models/device.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus_windows/device_info_plus_windows.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:flutter_vasat/models/device.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus_windows/device_info_plus_windows.dart that declares support for platforms: Windows.
Package does not support platform `Windows`.

Because:

  • package:flutter_vasat/models/device.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus_linux/device_info_plus_linux.dart that declares support for platforms: Linux.
Package does not support platform `Linux`.

Because:

  • package:flutter_vasat/models/device.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus_windows/device_info_plus_windows.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:flutter_vasat/models/device.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus_windows/device_info_plus_windows.dart that declares support for platforms: Windows.
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 34 issues. Showing the first 2:

ERROR: The argument type 'Object' can't be assigned to the parameter type 'Map

lib/storage/sembast_provider.dart:50:46

   ╷
50 │           return (factory != null) ? factory(value) : value as T;
   │                                              ^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/storage/sembast_provider.dart

WARNING: Unused import: 'package:flutter_vasat/models/vasat_model.dart'.

lib/models/device.dart:3:8

  ╷
3 │ import 'package:flutter_vasat/models/vasat_model.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/models/device.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
device_info_plus ^2.1.0 2.2.0 10.1.0
flutter flutter 0.0.0 0.0.0
http ^0.13.0 0.13.6 1.2.1
package_info_plus ^1.0.6 1.4.2 7.0.0
path ^1.8.0 1.9.0 1.9.0
path_provider ^2.0.3 2.0.15 2.1.3
rxdart ^0.27.2 0.27.7 0.27.7
sembast ^3.1.1 3.7.1 3.7.1
sembast_web ^2.0.1+1 2.3.0 2.3.0
shared_preferences ^2.0.7 2.2.3 2.2.3
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
device_info_plus_linux - 2.1.1 5.0.0
device_info_plus_macos - 2.2.3 5.0.0
device_info_plus_platform_interface - 2.6.1 7.0.0
device_info_plus_web - 2.1.0 5.0.0
device_info_plus_windows - 2.1.1 6.0.0
ffi - 1.2.1 2.1.2
file - 6.1.4 7.0.0
flutter_web_plugins - 0.0.0 0.0.0
http_parser - 4.0.2 4.0.2
idb_shim - 2.4.1+1 2.4.1+1
js - 0.7.1 0.7.1
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
package_info_plus_linux - 1.0.5 2.0.0
package_info_plus_macos - 1.3.0 2.0.0
package_info_plus_platform_interface - 1.0.2 3.0.0
package_info_plus_web - 1.0.6 2.0.0
package_info_plus_windows - 1.0.5 3.0.0
path_provider_android - 2.2.4 2.2.4
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.0.7 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
shared_preferences_android - 2.2.2 2.2.2
shared_preferences_foundation - 2.3.5 2.3.5
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
win32 - 2.6.1 5.4.0
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^2.1.0` on device_info_plus does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions device_info_plus to update the constraint.

The constraint `^0.13.0` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.