flutter_map_location_marker 9.0.0 copy "flutter_map_location_marker: ^9.0.0" to clipboard
flutter_map_location_marker: ^9.0.0 copied to clipboard

A flutter map plugin for displaying device current location.

135
likes
150/ 160
pub points
97%
popularity

We analyzed this package 3 days ago, and awarded it 150 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

102 out of 104 API elements (98.1 %) have documentation comments.

Some symbols that are missing documentation: flutter_map_location_marker.FollowOnLocationUpdate, flutter_map_location_marker.TurnOnHeadingUpdate.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:flutter_map_location_marker/flutter_map_location_marker.dart that imports:
  • package:flutter_map_location_marker/src/widgets/current_location_layer.dart that imports:
  • package:flutter_map_location_marker/src/data/data_stream_factory.dart that imports:
  • package:geolocator/geolocator.dart that imports:
  • package:geolocator_apple/geolocator_apple.dart that declares support for platforms: iOS, macOS.
Package does not support platform `iOS`.

Because:

  • package:flutter_map_location_marker/flutter_map_location_marker.dart that imports:
  • package:flutter_map_location_marker/src/widgets/current_location_layer.dart that imports:
  • package:flutter_map_location_marker/src/data/data_stream_factory.dart that imports:
  • package:geolocator/geolocator.dart that imports:
  • package:geolocator_android/geolocator_android.dart that declares support for platforms: Android.
Package does not support platform `Windows`.

Because:

  • package:flutter_map_location_marker/flutter_map_location_marker.dart that imports:
  • package:flutter_map_location_marker/src/widgets/current_location_layer.dart that imports:
  • package:flutter_map_location_marker/src/data/data_stream_factory.dart that imports:
  • package:geolocator/geolocator.dart that imports:
  • package:geolocator_apple/geolocator_apple.dart that declares support for platforms: iOS, macOS.
Package does not support platform `Linux`.

Because:

  • package:flutter_map_location_marker/flutter_map_location_marker.dart that imports:
  • package:flutter_map_location_marker/src/widgets/current_location_layer.dart that imports:
  • package:flutter_map_location_marker/src/data/data_stream_factory.dart that imports:
  • package:geolocator/geolocator.dart that declares support for platforms: Android, iOS, Windows, macOS, Web.
Package does not support platform `macOS`.

Because:

  • package:flutter_map_location_marker/flutter_map_location_marker.dart that imports:
  • package:flutter_map_location_marker/src/widgets/current_location_layer.dart that imports:
  • package:flutter_map_location_marker/src/data/data_stream_factory.dart that imports:
  • package:geolocator/geolocator.dart that imports:
  • package:geolocator_android/geolocator_android.dart that declares support for platforms: Android.
Package does not support platform `Web`.

Because:

  • package:flutter_map_location_marker/flutter_map_location_marker.dart that imports:
  • package:flutter_map_location_marker/src/widgets/current_location_layer.dart that imports:
  • package:flutter_map_location_marker/src/data/data_stream_factory.dart that imports:
  • package:geolocator/geolocator.dart that imports:
  • package:geolocator_apple/geolocator_apple.dart that declares support for platforms: iOS, macOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/src/options/focal_point.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_compass ^0.8.0 0.8.0 0.8.0
flutter_map ^7.0.0 7.0.1 7.0.1
geolocator ^12.0.0 12.0.0 12.0.0
latlong2 ^0.9.1 0.9.1 0.9.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.19.0
crypto - 3.0.3 3.0.3
dart_earcut - 1.1.0 1.1.0
fixnum - 1.1.0 1.1.0
flutter_web_plugins - 0.0.0 0.0.0
geolocator_android - 4.6.0 4.6.0
geolocator_apple - 2.3.7 2.3.7
geolocator_platform_interface - 4.2.4 4.2.4
geolocator_web - 4.0.0 4.0.0
geolocator_windows - 0.2.3 0.2.3
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.1.0
intl - 0.19.0 0.19.0
lists - 1.0.1 1.0.1
logger - 2.3.0 2.3.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
mgrs_dart - 2.0.0 2.0.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
polylabel - 1.0.1 1.0.1
proj4dart - 2.1.0 2.1.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
unicode - 0.3.1 0.3.1
uuid - 4.4.0 4.4.0
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
wkt_parser - 2.0.0 2.0.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.