flutter_gb_authentication_fire_social 3.0.0 copy "flutter_gb_authentication_fire_social: ^3.0.0" to clipboard
flutter_gb_authentication_fire_social: ^3.0.0 copied to clipboard

A utility package when integrating authentication with social media (facebook,apple,google) using BLoC pattern

1
likes
110/ 160
pub points
43%
popularity

We analyzed this package 3 hours ago, and awarded it 110 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-2-Clause.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

79 out of 398 API elements (19.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: advanced_bloc_builder, advanced_bloc_builder.AuthenticationAdvancedBlocBuilder, advanced_bloc_builder.AuthenticationAdvancedBlocBuilder.AuthenticationAdvancedBlocBuilder, advanced_bloc_builder.AuthenticationAdvancedBlocBuilder.builder, advanced_bloc_listener.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 4 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Linux`.

Because:

  • package:flutter_gb_authentication_fire_social/flutter_gb_authentication_fire_social.dart that imports:
  • package:flutter_gb_authentication_fire_social/presentation/presentation.dart that imports:
  • package:flutter_gb_authentication_fire_social/presentation/containers/containers.dart that imports:
  • package:flutter_gb_authentication_fire_social/presentation/containers/authentication_advanced_provider_container.dart that imports:
  • package:flutter_gb_authentication_basic/flutter_gb_authentication_basic.dart that imports:
  • package:flutter_gb_authentication_basic/infrastructure/infrastructure.dart that imports:
  • package:flutter_gb_authentication_basic/infrastructure/services/services.dart that imports:
  • package:flutter_gb_authentication_basic/infrastructure/services/authentication_service_impl.dart that imports:
  • package:flutter_gb_authentication_basic/infrastructure/models/auth_device_info_model.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32_registry/win32_registry.dart that declares support for platforms: Windows.
Package not compatible with platform Web

Because:

  • package:flutter_gb_authentication_fire_social/flutter_gb_authentication_fire_social.dart that imports:
  • package:flutter_gb_authentication_fire_social/utils/utils.dart that imports:
  • package:flutter_gb_authentication_fire_social/utils/logger.dart that imports:
  • package:logger/logger.dart that imports:
  • package:logger/src/outputs/advanced_file_output_stub.dart that imports:
  • dart:io

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:flutter_gb_authentication_fire_social/flutter_gb_authentication_fire_social.dart that imports:
  • package:flutter_gb_authentication_fire_social/presentation/presentation.dart that imports:
  • package:flutter_gb_authentication_fire_social/presentation/containers/containers.dart that imports:
  • package:flutter_gb_authentication_fire_social/presentation/containers/authentication_advanced_provider_container.dart that imports:
  • package:flutter_gb_authentication_basic/flutter_gb_authentication_basic.dart that imports:
  • package:flutter_gb_authentication_basic/infrastructure/infrastructure.dart that imports:
  • package:flutter_gb_authentication_basic/infrastructure/services/services.dart that imports:
  • package:flutter_gb_authentication_basic/infrastructure/services/authentication_service_impl.dart that imports:
  • package:flutter_gb_authentication_basic/infrastructure/models/auth_device_info_model.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32_registry/win32_registry.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:flutter_gb_authentication_fire_social/flutter_gb_authentication_fire_social.dart that imports:
  • package:flutter_gb_authentication_fire_social/presentation/presentation.dart that imports:
  • package:flutter_gb_authentication_fire_social/presentation/containers/containers.dart that imports:
  • package:flutter_gb_authentication_fire_social/presentation/containers/authentication_advanced_provider_container.dart that imports:
  • package:flutter_gb_authentication_basic/flutter_gb_authentication_basic.dart that imports:
  • package:flutter_gb_authentication_basic/infrastructure/infrastructure.dart that imports:
  • package:flutter_gb_authentication_basic/infrastructure/services/services.dart that imports:
  • package:flutter_gb_authentication_basic/infrastructure/services/authentication_service_impl.dart that imports:
  • package:flutter_gb_authentication_basic/infrastructure/models/auth_device_info_model.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32_registry/win32_registry.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:flutter_gb_authentication_fire_social/flutter_gb_authentication_fire_social.dart that imports:
  • package:flutter_gb_authentication_fire_social/presentation/presentation.dart that imports:
  • package:flutter_gb_authentication_fire_social/presentation/containers/containers.dart that imports:
  • package:flutter_gb_authentication_fire_social/presentation/containers/authentication_advanced_provider_container.dart that imports:
  • package:flutter_gb_authentication_basic/flutter_gb_authentication_basic.dart that imports:
  • package:flutter_gb_authentication_basic/infrastructure/infrastructure.dart that imports:
  • package:flutter_gb_authentication_basic/infrastructure/services/services.dart that imports:
  • package:flutter_gb_authentication_basic/infrastructure/services/authentication_service_impl.dart that imports:
  • package:flutter_gb_authentication_basic/infrastructure/models/auth_device_info_model.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32_registry/win32_registry.dart that declares support for platforms: Windows.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 41 issues. Showing the first 2:

WARNING: The member 'emit' can only be used within 'package:bloc/src/bloc.dart' or a test.

lib/application/bloc/authentication_social/authentication_social_bloc.dart:56:21

   ╷
56 │       authBasicBloc.emit(
   │                     ^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/application/bloc/authentication_social/authentication_social_bloc.dart

WARNING: The member 'emit' can only be used within 'package:bloc/src/bloc.dart' or a test.

lib/application/bloc/authentication_social/authentication_social_bloc.dart:74:25

   ╷
74 │           authBasicBloc.emit(
   │                         ^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/application/bloc/authentication_social/authentication_social_bloc.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
corsac_jwt ^1.0.0-nullsafety.1 1.0.0-nullsafety.1 1.0.0-nullsafety.1
dartz ^0.10.1 0.10.1 0.10.1
firebase_auth ^4.4.2 4.20.0 5.1.2
firebase_core ^2.10.0 2.32.0 3.2.0
flutter flutter 0.0.0 0.0.0
flutter_bloc ^8.1.3 8.1.6 8.1.6
flutter_gb_authentication_basic ^3.0.0 3.0.3 3.0.3
flutter_gb_stack_base ^2.0.0 2.0.1 2.0.1
freezed_annotation ^2.2.0 2.4.4 2.4.4
get_it ^7.6.0 7.7.0 7.7.0
http ^0.13.5 0.13.6 1.2.2
logger ^2.0.1 2.4.0 2.4.0
mockito ^5.4.0 5.4.4 5.4.4
rxdart ^0.27.7 0.27.7 0.28.0
shared_preferences ^2.1.2 2.2.3 2.2.3
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 67.0.0 73.0.0
_flutterfire_internals - 1.3.35 1.3.39
analyzer - 6.4.1 6.8.0
args - 2.5.0 2.5.0
asn1lib - 1.5.3 1.5.3
async - 2.11.0 2.11.0
auth_http_client - 1.3.1 1.3.1
auto_route - 7.9.2 8.3.0
bloc - 8.1.4 8.1.4
boolean_selector - 2.1.1 2.1.1
build - 2.4.1 2.4.1
built_collection - 5.1.1 5.1.1
built_value - 8.9.2 8.9.2
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
code_builder - 4.10.0 4.10.0
collection - 1.18.0 1.19.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
dart_style - 2.3.6 2.3.6
device_info_plus - 9.1.2 10.1.0
device_info_plus_platform_interface - 7.0.0 7.0.0
fake_async - 1.3.1 1.3.1
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
firebase_auth_platform_interface - 7.3.0 7.4.2
firebase_auth_web - 5.12.0 5.12.4
firebase_core_platform_interface - 5.1.0 5.1.0
firebase_core_web - 2.17.3 2.17.3
fixnum - 1.1.0 1.1.0
flutter_gb_built_utils - 1.0.1 1.0.1
flutter_test - 0.0.0 0.0.0
flutter_web_plugins - 0.0.0 0.0.0
gb_flutils - 3.0.0 3.0.0
glob - 2.1.2 2.1.2
http_parser - 4.0.2 4.1.0
js - 0.7.1 0.7.1
json_annotation - 4.9.0 4.9.0
leak_tracker - 10.0.4 10.0.5
leak_tracker_flutter_testing - 3.0.3 3.0.5
leak_tracker_testing - 3.0.1 3.0.1
logging - 1.2.0 1.2.0
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
nested - 1.0.0 1.0.0
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.3.0 2.3.0
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
pointycastle - 3.9.1 3.9.1
provider - 6.1.2 6.1.2
pub_semver - 2.1.4 2.1.4
rsa_pkcs - 2.1.0 2.1.0
shared_preferences_android - 2.2.3 2.2.3
shared_preferences_foundation - 2.4.0 2.4.0
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
source_gen - 1.5.0 1.5.0
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.3.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.3
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
vm_service - 14.2.1 14.2.4
watcher - 1.1.0 1.1.0
web - 0.5.1 1.0.0
win32 - 5.5.1 5.5.1
win32_registry - 1.1.3 1.1.3
xdg_directories - 1.0.4 1.0.4
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^4.4.2` on firebase_auth does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions firebase_auth to update the constraint.

The constraint `^2.10.0` on firebase_core does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions firebase_core to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.8, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.