flusmic_ui 3.0.0
flusmic_ui: ^3.0.0 copied to clipboard

A collection of widgets, utilities and extensions to integrate Flusmic more easy in Flutter.

2
likes
120/ 130
pub points
64%
popularity

We analyzed this package on Nov 29, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 38 out of 55 API elements (69.1 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support Flutter platform `Android`.

Because:

  • package:flusmic_ui/flusmic_ui.dart that imports:
  • package:flusmic_ui/src/flusmic_rich_text.dart that imports:
  • package:flusmic_ui/src/widgets/rich_image.dart that imports:
  • package:extended_image/extended_image.dart that imports:
  • package:extended_image/src/image/extended_render_image.dart that imports:
  • package:extended_image/src/extended_image_typedef.dart that imports:
  • package:extended_image/src/gesture/extended_image_slide_page.dart that imports:
  • package:extended_image/src/gesture/extended_image_slide_page_handler.dart that imports:
  • package:extended_image/src/gesture/extended_image_gesture_utils.dart that imports:
  • package:extended_image/src/extended_image_utils.dart that imports:
  • package:extended_image/src/extended_image.dart that imports:
  • package:extended_image/src/editor/extended_image_editor.dart that imports:
  • package:extended_image_library/extended_image_library.dart that imports:
  • package:extended_image_library/src/platform.dart that imports:
  • package:extended_image_library/src/_extended_network_image_utils_io.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
common_bloc^4.1.14.2.04.2.0
extended_image^4.1.04.2.15.1.3
flusmic^3.0.03.1.03.1.2
flutterflutter0.0.00.0.0
freezed_annotation^0.14.20.14.31.0.0
state_notifier^0.7.00.7.10.7.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-31.0.031.0.0
analyzer-2.8.02.8.0
async-2.8.22.8.2
bloc-7.2.18.0.1
bloc_concurrency-0.1.00.2.0
characters-1.1.01.2.0
charcode-1.3.11.3.1
cli_util-0.3.50.3.5
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-3.0.13.0.1
crypto-3.0.13.0.1
dio-4.0.44.0.4
extended_image_library-3.1.03.1.0
ffi-1.1.21.1.2
file-6.1.26.1.2
glob-2.0.22.0.2
http-0.13.40.13.4
http_client_helper-2.0.22.0.2
http_parser-4.0.04.0.0
intl-0.17.00.17.0
json_annotation-4.3.04.3.0
meta-1.7.01.7.0
package_config-2.0.22.0.2
path-1.8.01.8.0
path_provider-2.0.72.0.7
path_provider_android-2.0.92.0.9
path_provider_ios-2.0.72.0.7
path_provider_linux-2.1.22.1.2
path_provider_macos-2.0.32.0.3
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.42.0.4
petitparser-4.4.04.4.0
platform-3.0.23.0.2
plugin_platform_interface-2.0.22.0.2
process-4.2.44.2.4
pub_semver-2.1.02.1.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stream_transform-2.0.02.0.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
watcher-1.0.11.0.1
webfeed-0.7.00.7.0
win32-2.3.12.3.1
xdg_directories-0.2.00.2.0
xml-5.3.15.3.1
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.1.0` on extended_image does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions extended_image to update the constraint.

The constraint `^0.14.2` on freezed_annotation does not support the stable version `0.15.0`.

Try running dart pub upgrade --major-versions freezed_annotation to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

2
likes
120
pub points
64%
popularity

Publisher

pixela.tech

A collection of widgets, utilities and extensions to integrate Flusmic more easy in Flutter.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

common_bloc, extended_image, flusmic, flutter, freezed_annotation, state_notifier

More

Packages that depend on flusmic_ui