flusmic_ui 1.0.0+1

  • Readme
  • Changelog
  • Example
  • Installing
  • new56

flusmic_ui #

pub flusmic codecov Project Status: Active License: MIT style: effective dart

A collection of widgets, utilities and extensions to integrate Flusmic more easy in Flutter.

Getting Started #

Add Flusmic in your pubspec.yaml file.

dependencies:
  flusmic_ui: 1.0.0 /// latest version

Check our wiki to discover more.

Roadmap #

  • [X] FlusmicBuilder.
  • [X] FlusmicRichText: initial support (text and images).
  • [ ] FlusmicRichText: full text items support (lists, spans and links).
  • [ ] FlusmicRichText: embed items support.

[1.0.0+1] #

  • Update dependencies

[1.0.0] - Release #

  • Package created.
  • FlusmicBuilder
  • FlusmicRichText initial support.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'src/flsumic_rich_text.dart';
import 'src/flusmic_builder.dart';

void main() => runApp(FlusmicApp());

class FlusmicApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
        home: HomeFlusmicScreen(),
        theme: ThemeData(
            primaryColor: Color(0xFF5163BA),
            scaffoldBackgroundColor: Color(0xFFF5F6F9),
            accentColor: Color(0xFF35A86F)));
  }
}

class HomeFlusmicScreen extends StatefulWidget {
  @override
  _HomeFlusmicScreenState createState() => _HomeFlusmicScreenState();
}

class _HomeFlusmicScreenState extends State<HomeFlusmicScreen> {
  @override
  Widget build(BuildContext context) {
    return Scaffold(
        appBar: AppBar(title: Text('Flusmic example')),
        body: ListView(
            padding:
                const EdgeInsets.symmetric(horizontal: 24.0, vertical: 16.0),
            children: <Widget>[
              HomeItem(
                  Icons.build,
                  'A widget that is builded based on fetching state',
                  'FlusmicBuilder',
                  () => Navigator.of(context).push(MaterialPageRoute(
                      builder: (context) => FlusmicBuilderScreen()))),
              HomeItem(
                  Icons.text_fields,
                  'A widget for consume RichText',
                  'FlusmicRichText',
                  () => Navigator.of(context).push(MaterialPageRoute(
                      builder: (context) => FlusmicRichTextScreen())))
            ]));
  }
}

class HomeItem extends StatelessWidget {
  final IconData icon;
  final String subtitle;
  final String title;
  final VoidCallback onPressed;

  HomeItem(this.icon, this.subtitle, this.title, this.onPressed);

  @override
  Widget build(BuildContext context) {
    return Card(
        margin: const EdgeInsets.only(bottom: 8.0),
        clipBehavior: Clip.antiAlias,
        elevation: 3.0,
        shape:
            RoundedRectangleBorder(borderRadius: BorderRadius.circular(12.0)),
        child: InkWell(
            onTap: onPressed,
            borderRadius: BorderRadius.circular(12.0),
            splashColor: Theme.of(context).primaryColor,
            child: Padding(
                padding: const EdgeInsets.symmetric(
                    horizontal: 16.0, vertical: 32.0),
                child: Row(children: <Widget>[
                  Icon(icon, size: 40.0, color: Theme.of(context).accentColor),
                  SizedBox(width: 32.0),
                  Expanded(
                      child: Column(
                          crossAxisAlignment: CrossAxisAlignment.start,
                          children: <Widget>[
                        Text(title,
                            style: Theme.of(context).textTheme.headline4),
                        SizedBox(height: 16.0),
                        Text(subtitle)
                      ]))
                ]))));
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flusmic_ui: ^1.0.0+1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flusmic_ui/flusmic_ui.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
11
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
56
Learn more about scoring.

We analyzed this package on Jul 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform android

Because of import path [package:flusmic_ui/flusmic_ui.dart, package:flusmic_ui/src/flusmic_rich_text.dart, package:flusmic_ui/src/widgets/rich_image.dart, package:cached_network_image/cached_network_image.dart, package:cached_network_image/src/image_provider/cached_network_image_provider.dart, package:cached_network_image/src/image_provider/_image_provider_io.dart, package:flutter_cache_manager/flutter_cache_manager.dart, package:flutter_cache_manager/src/cache_manager.dart, package:path_provider/path_provider.dart, package:path_provider_linux/path_provider_linux.dart] that declares support for platforms: linux

Package does not support Flutter platform ios

Because of import path [package:flusmic_ui/flusmic_ui.dart, package:flusmic_ui/src/flusmic_rich_text.dart, package:flusmic_ui/src/widgets/rich_image.dart, package:cached_network_image/cached_network_image.dart, package:cached_network_image/src/image_provider/cached_network_image_provider.dart, package:cached_network_image/src/image_provider/_image_provider_io.dart, package:flutter_cache_manager/flutter_cache_manager.dart, package:flutter_cache_manager/src/cache_manager.dart, package:path_provider/path_provider.dart, package:path_provider_linux/path_provider_linux.dart] that declares support for platforms: linux

Package does not support Flutter platform linux

Because of import path [package:flusmic_ui/flusmic_ui.dart, package:flusmic_ui/src/flusmic_rich_text.dart, package:flusmic_ui/src/widgets/rich_image.dart, package:cached_network_image/cached_network_image.dart, package:cached_network_image/src/image_provider/cached_network_image_provider.dart, package:cached_network_image/src/image_provider/_image_provider_io.dart, package:flutter_cache_manager/flutter_cache_manager.dart, package:flutter_cache_manager/src/web/web_helper.dart, package:flutter_cache_manager/src/cache_store.dart, package:sqflite/sqflite.dart] that declares support for platforms: android, ios, macos

Package does not support Flutter platform macos

Because of import path [package:flusmic_ui/flusmic_ui.dart, package:flusmic_ui/src/flusmic_rich_text.dart, package:flusmic_ui/src/widgets/rich_image.dart, package:cached_network_image/cached_network_image.dart, package:cached_network_image/src/image_provider/cached_network_image_provider.dart, package:cached_network_image/src/image_provider/_image_provider_io.dart, package:flutter_cache_manager/flutter_cache_manager.dart, package:flutter_cache_manager/src/cache_manager.dart, package:path_provider/path_provider.dart, package:path_provider_linux/path_provider_linux.dart] that declares support for platforms: linux

Package does not support Flutter platform web

Because of import path [package:flusmic_ui/flusmic_ui.dart, package:flusmic_ui/src/flusmic_rich_text.dart, package:flusmic_ui/src/widgets/rich_image.dart, package:cached_network_image/cached_network_image.dart, package:cached_network_image/src/image_provider/cached_network_image_provider.dart, package:cached_network_image/src/image_provider/_image_provider_web.dart, package:flutter_cache_manager/flutter_cache_manager.dart, package:flutter_cache_manager/src/web/web_helper.dart, package:flutter_cache_manager/src/cache_store.dart, package:sqflite/sqflite.dart] that declares support for platforms: android, ios, macos

Package does not support Flutter platform windows

Because of import path [package:flusmic_ui/flusmic_ui.dart, package:flusmic_ui/src/flusmic_rich_text.dart, package:flusmic_ui/src/widgets/rich_image.dart, package:cached_network_image/cached_network_image.dart, package:cached_network_image/src/image_provider/cached_network_image_provider.dart, package:cached_network_image/src/image_provider/_image_provider_io.dart, package:flutter_cache_manager/flutter_cache_manager.dart, package:flutter_cache_manager/src/web/web_helper.dart, package:flutter_cache_manager/src/cache_store.dart, package:sqflite/sqflite.dart] that declares support for platforms: android, ios, macos

Package not compatible with SDK dart

because of import path [flusmic_ui] that is in a package requiring null.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.6.0 <3.0.0
cached_network_image ^2.2.0+1 2.2.0+1 2.3.0-rc
common_bloc ^2.0.3 2.0.3
flusmic ^2.0.0+2 2.0.0+2
flutter 0.0.0
freezed_annotation ^0.11.0 0.11.0
state_notifier ^0.5.0 0.5.0
Transitive dependencies
bloc 4.0.0 5.0.1
charcode 1.1.3
clock 1.0.1
collection 1.14.12 1.14.13
convert 2.1.1
crypto 2.1.5
dio 3.0.9
file 5.2.1
flutter_cache_manager 1.4.1
http 0.12.1
http_parser 3.1.4
intl 0.16.1
json_annotation 3.0.1
meta 1.1.8 1.2.1
path 1.7.0
path_provider 1.6.11
path_provider_linux 0.0.1+2
path_provider_macos 0.0.4+3
path_provider_platform_interface 1.0.2
pedantic 1.9.0 1.9.1
petitparser 3.0.4
platform 2.2.1
plugin_platform_interface 1.0.2
process 3.0.13
rxdart 0.24.1
sky_engine 0.0.99
source_span 1.7.0
sqflite 1.3.1
sqflite_common 1.0.2+1
string_scanner 1.0.5
synchronized 2.2.0+1
term_glyph 1.1.0
typed_data 1.1.6 1.2.0
uuid 2.2.0
vector_math 2.0.8
webfeed 0.4.2
xdg_directories 0.1.0
xml 3.7.0 4.2.0
Dev dependencies
build_runner ^1.10.0
effective_dart ^1.2.2
flutter_test
freezed ^0.11.0
mockito ^4.1.1