dwds 24.0.0 copy "dwds: ^24.0.0" to clipboard
dwds: ^24.0.0 copied to clipboard

A service that proxies between the Chrome debug protocol and the Dart VM service protocol.

27
likes
130/ 160
pub points
100%
popularity

We analyzed this package 2 days ago, and awarded it 130 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

257 out of 556 API elements (46.2 %) have documentation comments.

Some symbols that are missing documentation: asset_reader, asset_reader.stripLeadingSlashes, batched_stream, build_result, build_result.BuildResult.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:dwds/dwds.dart that imports:
  • package:dwds/src/utilities/sdk_configuration.dart that imports:
  • package:file/local.dart that imports:
  • package:file/src/backends/local.dart that imports:
  • package:file/src/backends/local/local_file_system.dart that imports:
  • package:file/src/backends/local/local_link.dart that imports:
  • package:file/src/backends/local/local_file_system_entity.dart that imports:
  • package:file/src/backends/local/local_file.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: 'whereNotNull' is deprecated and shouldn't be used. Use .nonNulls instead.

lib/src/debugging/inspector.dart:116:64

    ╷
116 │     DartUri.recordAbsoluteUris(libraries.map((lib) => lib.uri).whereNotNull());
    │                                                                ^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/debugging/inspector.dart

INFO: 'whereNotNull' is deprecated and shouldn't be used. Use .nonNulls instead.

lib/src/debugging/inspector.dart:118:43

    ╷
118 │       scripts.map((script) => script.uri).whereNotNull(),
    │                                           ^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/debugging/inspector.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
async ^2.9.0 2.11.0 2.11.0
built_collection ^5.1.1 5.1.1 5.1.1
built_value ^8.3.0 8.9.2 8.9.2
collection ^1.15.0 1.19.0 1.19.0
crypto ^3.0.2 3.0.3 3.0.3
dds ^4.1.0 4.2.3 4.2.3
file >=6.0.0 <8.0.0 7.0.0 7.0.0
http ^0.13.4 0.13.6 1.2.1
http_multi_server ^3.2.0 3.2.1 3.2.1
logging ^1.0.2 1.2.0 1.2.0
meta ^1.7.0 1.15.0 1.15.0
package_config ^2.0.2 2.1.0 2.1.0
path ^1.8.1 1.9.0 1.9.0
pool ^1.5.0 1.5.1 1.5.1
pub_semver ^2.1.1 2.1.4 2.1.4
shelf ^1.3.0 1.4.2 1.4.2
shelf_packages_handler ^3.0.0 3.0.2 3.0.2
shelf_proxy ^1.0.1 1.0.4 1.0.4
shelf_static ^1.1.0 1.1.2 1.1.2
shelf_web_socket ^1.0.1 1.0.4 2.0.0
source_maps ^0.10.10 0.10.12 0.10.12
sse ^4.1.2 4.1.5 4.1.5
stack_trace ^1.10.0 1.11.1 1.11.1
uuid ^3.0.6 3.0.7 4.4.0
vm_service ^14.0.0 14.2.4 14.2.4
vm_service_interface 1.1.0 1.1.0 1.1.0
web_socket_channel ^2.2.0 2.4.5 3.0.0
webkit_inspection_protocol ^1.0.1 1.2.1 1.2.1
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
browser_launcher - 1.1.1 1.1.1
clock - 1.1.1 1.1.1
convert - 3.1.1 3.1.1
dap - 1.2.0 1.2.0
dds_service_extensions - 2.0.0 2.0.0
devtools_shared - 10.0.1 10.0.1
dtd - 2.2.0 2.2.0
extension_discovery - 2.0.0 2.0.0
fixnum - 1.1.0 1.1.0
http_parser - 4.1.0 4.1.0
intl - 0.19.0 0.19.0
json_rpc_2 - 3.0.2 3.0.2
mime - 1.0.5 1.0.5
source_span - 1.10.0 1.10.0
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
unified_analytics - 6.1.1 6.1.1
web - 0.5.1 0.5.1
yaml - 3.1.2 3.1.2
yaml_edit - 2.2.1 2.2.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^0.13.4` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint `^1.0.1` on shelf_web_socket does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions shelf_web_socket to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Dart 3.4.3.

Check the analysis log for details.