dash_kit_control_panel 1.0.1
dash_kit_control_panel: ^1.0.1 copied to clipboard

Flutter Android iOS

Revolutionary tool for configuration Flutter apps

0
likes
60 / 110
pub points
42 %
popularity

We analyzed this package on Feb 25, 2021, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 17 out of 109 API elements (15.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:dash_kit_control_panel/dash_kit_control_panel.dart that imports:
  • package:dash_kit_control_panel/src/ui/components/version/version_setting.dart that imports:
  • package:package_info/package_info.dart that declares support for platforms: Android, iOS, macOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'WhitelistingTextInputFormatter' is deprecated and shouldn't be used. Use FilteringTextInputFormatter.allow instead. This feature was deprecated after v1.20.0-1.0.pre..

lib/src/ui/components/proxy/proxy_setting.dart:167:25

    ╷
167 │       inputFormatters: [WhitelistingTextInputFormatter(RegExp('[0-9\.]'))],
    │                         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/ui/components/proxy/proxy_setting.dart

lib/src/ui/components/device_preview/device_preview_setting.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
alice_lightweight^1.0.01.0.21.0.2
device_preview^0.4.80.4.80.5.5
flutterflutter0.0.00.0.0
logger^0.9.40.9.40.9.4
package_info^0.4.30.4.3+42.0.0
rxdart^0.24.10.24.10.25.0
shared_preferences^0.5.120.5.12+42.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
charcode-1.1.31.2.0
collection-1.15.0-nullsafety.31.15.0
dio-3.0.103.0.10
ffi-0.1.31.0.0
file-5.2.16.1.0
flutter_localizations-0.0.00.0.0
flutter_web_plugins-0.0.00.0.0
font_awesome_flutter-8.11.08.11.0
freezed_annotation-0.11.0+10.12.0
http-0.12.20.13.0
http_parser-3.1.44.0.0
intl-0.16.10.17.0
json_annotation-3.1.14.0.0
meta-1.3.0-nullsafety.31.3.0
mime-0.9.71.0.0
path-1.8.0-nullsafety.11.8.0
path_provider-1.6.272.0.0
path_provider_linux-0.0.1+22.0.0
path_provider_macos-0.0.4+82.0.0
path_provider_platform_interface-1.0.42.0.0
path_provider_windows-0.0.4+32.0.0
pedantic-1.9.21.10.0
platform-2.2.13.0.0
plugin_platform_interface-1.0.32.0.0
process-3.0.134.1.0
share-0.6.5+42.0.0
shared_preferences_linux-0.0.2+42.0.0
shared_preferences_macos-0.0.1+112.0.0
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.0
shared_preferences_windows-0.0.2+32.0.0
sky_engine-0.0.990.0.99
source_span-1.7.01.8.1
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0
win32-1.7.4+12.0.0
xdg_directories-0.1.20.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^0.4.8` on device_preview does not support the latest published version `0.5.5`

pubspec.yaml:16:19

   ╷
16 │   device_preview: ^0.4.8
   │                   ^^^^^^
   ╵
The constraint `^0.4.3` on package_info does not support the latest published version `2.0.0`

pubspec.yaml:14:17

   ╷
14 │   package_info: ^0.4.3
   │                 ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Flutter 1.22.6, Dart 2.10.5.