dart_define 2.1.1 copy "dart_define: ^2.1.1" to clipboard
dart_define: ^2.1.1 copied to clipboard

Utility for generating and populating dart-define config files

15
likes
110/ 140
pub points
73%
popularity

We analyzed this package 3 days ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

1 out of 1 API elements (100.0 %) have documentation comments.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/model/src/argument_variable.gen.dart:119:17

    ╷
119 │   bool operator ==(dynamic other) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/model/src/argument_variable.gen.dart

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/model/src/dart_define_configuration.gen.dart:280:17

    ╷
280 │   bool operator ==(dynamic other) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/model/src/dart_define_configuration.gen.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
args ^2.4.1 2.5.0 2.5.0
checked_yaml ^2.0.3 2.0.3 2.0.3
cli_completion ^0.3.0 0.3.0 0.5.0
cmd_plus ^1.3.2 1.3.3 1.3.3
freezed_annotation ^2.2.0 2.4.1 2.4.1
json_annotation ^4.8.1 4.8.1 4.8.1
mankeli_core ^0.0.5 0.0.5 0.0.5
mustache_template ^2.0.0 2.0.0 2.0.0
path ^1.8.3 1.9.0 1.9.0
pub_updater ^0.3.0 0.3.1 0.4.0
yaml ^3.1.2 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 67.0.0 67.0.0
analyzer - 6.4.1 6.4.1
async - 2.11.0 2.11.0
build - 2.4.1 2.4.1
build_config - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
dart_style - 2.3.6 2.3.6
equatable - 2.0.5 2.0.5
ffi - 2.1.2 2.1.2
file - 6.1.4 7.0.0
freezed - 2.5.2 2.5.2
glob - 2.1.2 2.1.2
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
io - 1.0.4 1.0.4
logger - 1.4.0 2.2.0
logging - 1.2.0 1.2.0
mason_logger - 0.2.12 0.2.12
meta - 1.14.0 1.14.0
package_config - 2.1.0 2.1.0
platform - 3.1.4 3.1.4
process - 4.2.4 5.0.2
pub_semver - 2.1.4 2.1.4
pubspec_parse - 1.2.3 1.2.3
source_gen - 1.5.0 1.5.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
watcher - 1.1.0 1.1.0
web - 0.5.1 0.5.1
win32 - 5.4.0 5.4.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.3.0` on cli_completion does not support the stable version `0.4.0`.

Try running dart pub upgrade --major-versions cli_completion to update the constraint.

The constraint `^0.3.0` on pub_updater does not support the stable version `0.4.0`.

Try running dart pub upgrade --major-versions pub_updater to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.3.

Check the analysis log for details.