custom_form_builder 1.0.0-dev.3 icon indicating copy to clipboard operation
custom_form_builder: ^1.0.0-dev.3 copied to clipboard

Package to build Material Form with fields like TextField, DropDown, Switches etc. with ability to create custom FormFields and composability and reuse validation functions.

0
likes
60/ 130
pub points
51%
popularity

We analyzed this package 3 days ago, and awarded it 60 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
10 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Repository URL doesn't exist.

At the time of the analysis https://github.com/AKWAD-Dragons/custom_form_builder was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 90 out of 748 API elements (12.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform Support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:custom_form_builder/custom_form_builder.dart that imports:
  • package:custom_form_builder/src/fields/form_builder_typeahead.dart that imports:
  • package:flutter_typeahead/flutter_typeahead.dart that imports:
  • package:flutter_keyboard_visibility/flutter_keyboard_visibility.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:custom_form_builder/custom_form_builder.dart that imports:
  • package:custom_form_builder/src/fields/form_builder_typeahead.dart that imports:
  • package:flutter_typeahead/flutter_typeahead.dart that imports:
  • package:flutter_keyboard_visibility/flutter_keyboard_visibility.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:custom_form_builder/custom_form_builder.dart that imports:
  • package:custom_form_builder/src/fields/form_builder_typeahead.dart that imports:
  • package:flutter_typeahead/flutter_typeahead.dart that imports:
  • package:flutter_keyboard_visibility/flutter_keyboard_visibility.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Web`.

Because:

  • package:custom_form_builder/custom_form_builder.dart that imports:
  • package:custom_form_builder/src/fields/form_builder_phone_field.dart that imports:
  • package:phone_number/phone_number.dart that declares support for platforms: Android, iOS.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 16 issues. Showing the first 2:

lib/src/fields/form_builder_checkbox_list.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/fields/form_builder_chips_choice.dart doesn't match the Dart formatter.

To format your files run: flutter format .

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run flutter pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
The current Dart SDK version is 2.15.1.

Because test >=1.16.0-nullsafety <1.16.0-nullsafety.8 requires SDK version >=2.10.0-0 <2.12.0 and test >=1.16.0-nullsafety.8 <1.16.0-nullsafety.18 depends on typed_data >=1.3.0-nullsafety <1.3.0,[...]
And because test >=1.16.0-nullsafety.18 <1.16.0 depends on pedantic ^1.10.0-nullsafety, test >=1.16.0-nullsafety <1.16.0 requires typed_data >=1.3.0-nullsafety <1.3.0 or pedantic ^1.10.0-nullsafety.
And because test >=1.3.0 <1.12.0 depends on boolean_selector ^1.0.0 and test >=1.12.0 <1.13.0 depends on test_api 0.2.14, test >=1.3.0 <1.13.0-∞ or >=1.16.0-nullsafety <1.16.0 requires typed_data[...]
And because test >=1.13.0 <1.14.5 depends on test_api 0.2.15 and test >=1.14.5 <1.15.0 depends on test_api 0.2.16, test >=1.3.0 <1.15.0-∞ or >=1.16.0-nullsafety <1.16.0 requires typed_data >=1.3.[...]
And because test >=1.15.0 <1.15.3 depends on test_api 0.2.17 and test >=1.15.3 <1.15.5 depends on test_api 0.2.18, test >=1.3.0 <1.15.5-∞ or >=1.16.0-nullsafety <1.16.0 requires typed_data >=1.3.[...]
And because test >=1.15.5 <1.16.0-nullsafety depends on test_api 0.2.18+1 and test >=1.16.0 <1.18.0 depends on pedantic ^1.10.0, test >=1.3.0 <1.18.0 requires typed_data >=1.3.0-nullsafety <1.3.0[...]
And because test >=1.18.0 <1.18.1 depends on test_api 0.4.4 and test >=1.18.1 <1.19.0 depends on test_api 0.4.5, test >=1.3.0 <1.19.0 requires typed_data >=1.3.0-nullsafety <1.3.0 or pedantic ^1.[...]
And because test >=1.19.0 <1.19.3 depends on test_api 0.4.6 and test >=1.19.3 <1.19.4 depends on test_api 0.4.7, test >=1.3.0 <1.19.4 requires typed_data >=1.3.0-nullsafety <1.3.0 or pedantic ^1.[...]
[4 more lines]

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.6.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.5, Flutter 2.8.1, Dart 2.15.1.

0
likes
60
pub points
51%
popularity

Package to build Material Form with fields like TextField, DropDown, Switches etc. with ability to create custom FormFields and composability and reuse validation functions.

Repository (missing)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

country_pickers, date_range_picker, datetime_picker_formfield, flutter, flutter_colorpicker, flutter_touch_spin, flutter_typeahead, group_radio_button, image_picker, intl, phone_number, rating_bar, signature, validators

More

Packages that depend on custom_form_builder