date_range_picker 1.0.6

  • Readme
  • Changelog
  • Installing
  • 85
Awesome Flutter pub version

Date Range Picker #

Flutter date range pickers use a dialog window to select a range of date on mobile.

Demo #

Getting Started #

Installation #

Add to pubspec.yaml in dependencies

  date_range_picker: ^1.0.5

Usage #

import 'package:date_range_picker/date_range_picker.dart' as DateRagePicker;
...
new MaterialButton(
    color: Colors.deepOrangeAccent,
    onPressed: () async {
      final List<DateTime> picked = await DateRagePicker.showDatePicker(
          context: context,
          initialFirstDate: new DateTime.now(),
          initialLastDate: (new DateTime.now()).add(new Duration(days: 7)),
          firstDate: new DateTime(2015),
          lastDate: new DateTime(2020)
      );
      if (picked != null && picked.length == 2) {
          print(picked);
      }
    },
    child: new Text("Pick date range")
)

[1.0.0] - Basic date range picker. #

[1.0.1] - Format code #

[1.0.2] - Fixed two run time exceptions #

[1.0.3] - Fix landscape mode #

[1.0.4] - Don't add date to array if date is null #

[1.0.5] - Fix wrong type of list #

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  date_range_picker: ^1.0.6

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:date_range_picker/date_range_picker.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
97
Health:
Code health derived from static analysis. [more]
81
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
59
Overall:
Weighted score of the above. [more]
85
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

because of import path [date_range_picker] that is in a package requiring null.

Health issues and suggestions

Fix lib/date_range_picker.dart. (-19.27 points)

Analysis of lib/date_range_picker.dart reported 3 warnings, 12 hints, including:

line 1051 col 5: Missing case clause for 'linux'.

line 1051 col 5: Missing case clause for 'macOS'.

line 1051 col 5: Missing case clause for 'windows'.

line 96 col 25: 'display1' is deprecated and shouldn't be used. This is the term used in the 2014 version of material design. The modern term is headline4. This feature was deprecated after v1.13.8..

line 98 col 25: 'subhead' is deprecated and shouldn't be used. This is the term used in the 2014 version of material design. The modern term is subtitle1. This feature was deprecated after v1.13.8..

Maintenance suggestions

Package is getting outdated. (-30.96 points)

The package was last published 68 weeks ago.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and date_range_picker.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test