corbado_auth 2.0.4 copy "corbado_auth: ^2.0.4" to clipboard
corbado_auth: ^2.0.4 copied to clipboard

Flutter package for Corbado Auth. Enables authentication on Android and iOS using passkeys.

6
likes
130/ 140
pub points
80%
popularity

We analyzed this package 27 hours ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

123 out of 240 API elements (51.2 %) have documentation comments.

Some symbols that are missing documentation: corbado_auth.AllowCredential, corbado_auth.AllowCredential.AllowCredential.fromJson, corbado_auth.AllowCredential.toJson, corbado_auth.AuthState, corbado_auth.AuthState.AuthState.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:corbado_auth/corbado_auth.dart that imports:
  • package:corbado_auth/src/types/types.dart that imports:
  • package:corbado_auth/src/types/webauthn/types.dart that imports:
  • package:corbado_auth/src/types/webauthn/registration.dart that imports:
  • package:passkeys/types.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:corbado_auth/corbado_auth.dart that imports:
  • package:corbado_auth/src/types/types.dart that imports:
  • package:corbado_auth/src/types/webauthn/types.dart that imports:
  • package:corbado_auth/src/types/webauthn/registration.dart that imports:
  • package:passkeys/types.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:corbado_auth/corbado_auth.dart that imports:
  • package:corbado_auth/src/types/types.dart that imports:
  • package:corbado_auth/src/types/webauthn/types.dart that imports:
  • package:corbado_auth/src/types/webauthn/registration.dart that imports:
  • package:passkeys/types.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Web`.

Because:

  • package:corbado_auth/corbado_auth.dart that imports:
  • package:corbado_auth/src/corbado_auth.dart that imports:
  • package:corbado_auth/src/services/storage/storage_native.dart that imports:
  • package:flutter_keychain/flutter_keychain.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 15 issues. Showing the first 2:

INFO: The import of 'package:corbado_auth/src/types/exceptions/exceptions.dart' is unnecessary because all of the used elements are also provided by the import of 'package:corbado_auth/corbado_auth.dart'.

lib/src/services/corbado/corbado.dart:6:8

  ╷
6 │ import 'package:corbado_auth/src/types/exceptions/exceptions.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/services/corbado/corbado.dart

INFO: The import of 'package:corbado_auth/src/types/webauthn/authentication.dart' is unnecessary because all of the used elements are also provided by the import of 'package:corbado_auth/corbado_auth.dart'.

lib/src/services/corbado/corbado.dart:8:8

  ╷
8 │ import 'package:corbado_auth/src/types/webauthn/authentication.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/services/corbado/corbado.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
corbado_frontend_api_client ^1.0.0 1.1.0 1.1.0
flutter flutter 0.0.0 0.0.0
flutter_keychain ^2.4.0 2.4.0 2.4.0
http ^1.1.2 1.2.1 1.2.1
json_annotation ^4.8.1 4.8.1 4.8.1
jwt_decoder ^2.0.1 2.0.1 2.0.1
passkeys ^2.0.4 2.0.4 2.0.4
rxdart ^0.27.7 0.27.7 0.27.7
ua_client_hints ^1.1.3 1.2.2 1.2.2
universal_html ^2.2.4 2.2.4 2.2.4
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
charcode - 1.3.1 1.3.1
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
csslib - 1.0.0 1.0.0
flutter_web_plugins - 0.0.0 0.0.0
html - 0.15.4 0.15.4
http_parser - 4.0.2 4.0.2
intl - 0.18.1 0.19.0
js - 0.6.7 0.7.1
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
openapi_generator_annotations - 4.13.1 5.0.2
passkeys_android - 2.0.2 2.0.2
passkeys_ios - 2.0.2 2.0.2
passkeys_platform_interface - 2.0.1 2.0.1
passkeys_web - 2.0.1 2.0.1
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
universal_io - 2.2.2 2.2.2
vector_math - 2.1.4 2.1.4
web - 0.5.0 0.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.