coder0211 0.1.3 icon indicating copy to clipboard operation
coder0211: ^0.1.3 copied to clipboard

This is a package with functions and widgets to make app development faster and more convenient, currently it is developed by one developer.

29
likes
140/ 140
pub points
38%
popularity

We analyzed this package 2 hours ago, and awarded it 140 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 93 out of 228 API elements (40.8 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:coder0211/coder0211.dart that imports:
  • package:coder0211/src/extensions/double_extension.dart that imports:
  • package:coder0211/src/base_handle/base_utils.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:coder0211/coder0211.dart that imports:
  • package:coder0211/src/extensions/double_extension.dart that imports:
  • package:coder0211/src/base_handle/base_utils.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:coder0211/coder0211.dart that imports:
  • package:coder0211/src/extensions/double_extension.dart that imports:
  • package:coder0211/src/base_handle/base_utils.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS, Web.
Package not compatible with platform Web

Because:

  • package:coder0211/coder0211.dart that imports:
  • package:coder0211/src/base_api/base_api.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
auto_size_text^3.0.03.0.03.0.0
connectivity^3.0.63.0.63.0.6
dio^4.0.64.0.64.0.6
flutterflutter0.0.00.0.0
flutter_mobx^2.0.6+42.0.6+52.0.6+5
flutter_svg^1.0.01.1.62.0.0
fluttertoast^8.0.98.1.28.1.2
google_fonts^3.0.13.0.14.0.1
image_picker^0.8.4+40.8.6+10.8.6+1
loading_indicator^3.1.03.1.03.1.0
mobx^2.1.12.1.32.1.3
provider^6.0.46.0.56.0.5
qr_flutter^4.0.04.0.04.0.0
shared_preferences^2.0.112.0.172.0.17
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.10.02.10.0
characters-1.2.11.2.1
collection-1.17.01.17.1
connectivity_for_web-0.4.0+10.4.0+1
connectivity_macos-0.2.1+20.2.1+2
connectivity_platform_interface-2.0.12.0.1
cross_file-0.3.3+40.3.3+4
crypto-3.0.23.0.2
ffi-2.0.12.0.1
file-6.1.46.1.4
flutter_plugin_android_lifecycle-2.0.72.0.7
flutter_web_plugins-0.0.00.0.0
http-0.13.50.13.5
http_parser-4.0.24.0.2
image_picker_android-0.8.5+50.8.5+5
image_picker_for_web-2.1.102.1.10
image_picker_ios-0.8.6+60.8.6+6
image_picker_platform_interface-2.6.22.6.2
js-0.6.50.6.7
material_color_utilities-0.2.00.2.0
meta-1.8.01.9.0
nested-1.0.01.0.0
path-1.8.31.8.3
path_drawing-1.0.11.0.1
path_parsing-1.0.11.0.1
path_provider-2.0.122.0.12
path_provider_android-2.0.222.0.22
path_provider_foundation-2.1.12.1.1
path_provider_linux-2.1.72.1.7
path_provider_platform_interface-2.0.52.0.5
path_provider_windows-2.1.32.1.3
petitparser-5.1.05.1.0
platform-3.1.03.1.0
plugin_platform_interface-2.1.32.1.3
process-4.2.44.2.4
qr-2.1.03.0.1
shared_preferences_android-2.0.152.0.15
shared_preferences_foundation-2.1.32.1.3
shared_preferences_linux-2.1.32.1.3
shared_preferences_platform_interface-2.1.02.1.0
shared_preferences_web-2.0.42.0.4
shared_preferences_windows-2.1.32.1.3
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.42.1.4
win32-3.1.34.1.1
xdg_directories-0.2.0+30.2.0+3
xml-6.2.26.2.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.0` on flutter_svg does not support the stable version `2.0.0`, that was published 0 days ago.

When flutter_svg is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions flutter_svg to update the constraint.

The constraint `^3.0.1` on google_fonts does not support the stable version `4.0.0`, that was published 6 days ago.

When google_fonts is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions google_fonts to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.

29
likes
140
pub points
38%
popularity

Publisher

unverified uploader

This is a package with functions and widgets to make app development faster and more convenient, currently it is developed by one developer.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

auto_size_text, connectivity, dio, flutter, flutter_mobx, flutter_svg, fluttertoast, google_fonts, image_picker, loading_indicator, mobx, provider, qr_flutter, shared_preferences

More

Packages that depend on coder0211