catcher 0.3.22
catcher: ^0.3.22

Flutter Android iOS web

Plugin for error catching. Allows handling errors when they're not catched by developer. Plugin provides multiple handlers for errors.

143
likes
100 / 110
pub points
95 %
popularity

We analyzed this package on Nov 26, 2020, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 102 out of 305 API elements (33.4 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:catcher/catcher.dart that declares support for platforms: Android, iOS, Web
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
device_info^0.4.2+90.4.2+101.0.0
dio^3.0.103.0.103.0.10
flutter_mailer^1.0.01.0.11.0.1
fluttertoast^7.0.1+17.1.47.1.4
logging^0.11.40.11.40.11.4
mailer^3.2.13.2.13.2.1
package_info^0.4.30.4.3+20.4.3+2
sentry^3.0.0+13.0.13.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.4.22.4.2
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.1.3
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
device_info_platform_interface-1.0.11.0.1
http-0.12.20.12.2
http_parser-3.1.43.1.4
intl-0.16.10.16.1
js-0.6.3-nullsafety.30.6.3-nullsafety.3
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
mime-0.9.70.9.7
path-1.7.01.7.0
pedantic-1.9.21.9.2
plugin_platform_interface-1.0.31.0.3
source_span-1.7.01.7.0
stack_trace-1.9.61.9.6
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
usage-3.4.23.4.2
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.4.2+9` on device_info does not support the latest published version `1.0.0`

pubspec.yaml:17:16

   ╷
17 │   device_info: ^0.4.2+9
   │                ^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

143
likes
100
pub points
95%
popularity

Plugin for error catching. Allows handling errors when they're not catched by developer. Plugin provides multiple handlers for errors.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

jhomlala@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

device_info, dio, flutter, flutter_mailer, flutter_web_plugins, fluttertoast, logging, mailer, package_info, sentry

More

Packages that depend on catcher