catcher 0.3.17

Flutter Android iOS web

Plugin for error catching. Allows handling errors when they're not catched by developer. Plugin provides multiple handlers for errors.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  catcher: ^0.3.17

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:catcher/catcher.dart';
90
likes
110
pub points
94%
popularity

Plugin for error catching. Allows handling errors when they're not catched by developer. Plugin provides multiple handlers for errors.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

jhomlala@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

device_info, dio, flutter, flutter_mailer, flutter_web_plugins, fluttertoast, logging, mailer, package_info, sentry

More

Packages that depend on catcher