bytedesk_kefu 1.6.4 icon indicating copy to clipboard operation
bytedesk_kefu: ^1.6.4 copied to clipboard

the best app chat sdk in china, you can chat with the agent freely at anytime. the agent can chat with the visitor by web/pc/mac/ios/android client.

8
likes
110/ 140
pub points
43%
popularity

We analyzed this package 5 hours ago, and awarded it 110 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

2554 out of 5921 API elements (43.1 %) have documentation comments.

Some symbols that are missing documentation: anchor, AnchorKey, forId, id, of.

10/10 points: Package has an example

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:bytedesk_kefu/bytedesk_kefu.dart that imports:
  • package:bytedesk_kefu/ui/chat/provider/chat_kf_provider.dart that imports:
  • package:bytedesk_kefu/ui/chat/page/chat_kf_page.dart that imports:
  • package:bytedesk_kefu/ui/chat/widget/message_widget.dart that imports:
  • package:bytedesk_kefu/ui/chat/page/video_play_page.dart that imports:
  • package:chewie/chewie.dart that imports:
  • package:chewie/src/material/material_desktop_controls.dart that imports:
  • package:chewie/src/chewie_player.dart that imports:
  • package:wakelock_plus/wakelock_plus.dart that imports:
  • package:wakelock_plus/src/wakelock_plus_windows_plugin.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:bytedesk_kefu/bytedesk_kefu.dart that imports:
  • package:bytedesk_kefu/ui/chat/provider/chat_kf_provider.dart that imports:
  • package:bytedesk_kefu/ui/chat/page/chat_kf_page.dart that imports:
  • package:bytedesk_kefu/ui/chat/widget/message_widget.dart that imports:
  • package:bytedesk_kefu/ui/chat/page/video_play_page.dart that imports:
  • package:chewie/chewie.dart that imports:
  • package:chewie/src/material/material_desktop_controls.dart that imports:
  • package:chewie/src/chewie_player.dart that imports:
  • package:wakelock_plus/wakelock_plus.dart that imports:
  • package:wakelock_plus/src/wakelock_plus_windows_plugin.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `Windows`.

Because:

  • package:bytedesk_kefu/bytedesk_kefu.dart that imports:
  • package:bytedesk_kefu/ui/leavemsg/provider/leavemsg_history_provider.dart that imports:
  • package:bytedesk_kefu/blocs/leavemsg_bloc/leavemsg_bloc.dart that imports:
  • package:bytedesk_kefu/util/bytedesk_utils.dart that imports:
  • package:image_gallery_saver/image_gallery_saver.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:bytedesk_kefu/bytedesk_kefu.dart that imports:
  • package:bytedesk_kefu/ui/leavemsg/provider/leavemsg_history_provider.dart that imports:
  • package:bytedesk_kefu/blocs/leavemsg_bloc/leavemsg_bloc.dart that imports:
  • package:bytedesk_kefu/util/bytedesk_utils.dart that imports:
  • package:image_gallery_saver/image_gallery_saver.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:bytedesk_kefu/bytedesk_kefu.dart that imports:
  • package:bytedesk_kefu/ui/leavemsg/provider/leavemsg_history_provider.dart that imports:
  • package:bytedesk_kefu/blocs/leavemsg_bloc/leavemsg_bloc.dart that imports:
  • package:bytedesk_kefu/util/bytedesk_utils.dart that imports:
  • package:image_gallery_saver/image_gallery_saver.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:bytedesk_kefu/bytedesk_kefu.dart that imports:
  • package:bytedesk_kefu/ui/leavemsg/provider/leavemsg_history_provider.dart that imports:
  • package:bytedesk_kefu/blocs/leavemsg_bloc/leavemsg_bloc.dart that imports:
  • package:bytedesk_kefu/util/bytedesk_utils.dart that imports:
  • package:image_gallery_saver/image_gallery_saver.dart that declares support for platforms: Android, iOS.
icon indicating section status
Pass static analysis
40 / 50icon to trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 87 issues. Showing the first 2:

INFO: Unnecessary use of getter and setter to wrap a field.

lib/mqtt/lib/src/messages/connect/mqtt_client_mqtt_connect_payload.dart:24:14

   ╷
24 │   String get clientIdentifier => _clientIdentifier;
   │              ^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/mqtt/lib/src/messages/connect/mqtt_client_mqtt_connect_payload.dart

INFO: 'textScaleFactor' is deprecated and shouldn't be used. Use textScaler instead. Use of textScaleFactor was deprecated in preparation for the upcoming nonlinear text scaling support. This feature was deprecated after v3.12.0-2.0.pre.

lib/ui/chat/widget/flutter_html/html_parser.dart:108:49

    ╷
108 │         textScaleFactor: MediaQuery.of(context).textScaleFactor,
    │                                                 ^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/ui/chat/widget/flutter_html/html_parser.dart

icon indicating section status
Support up-to-date dependencies
0 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
bloc ^8.1.2 8.1.2 8.1.2
cached_network_image ^3.2.3 3.3.0 3.3.0
chewie ^1.7.0 1.7.4 1.7.4
collection ^1.17.1 1.18.0 1.18.0
crypto ^3.0.3 3.0.3 3.0.3
css_colors ^1.1.1 1.1.3 1.1.3
csslib ^0.17.3 0.17.3 1.0.0
equatable ^2.0.5 2.0.5 2.0.5
event_bus ^2.0.0 2.0.0 2.0.0
flutter flutter 0.0.0 0.0.0
flutter_bloc ^8.1.3 8.1.3 8.1.3
flutter_cache_manager ^3.3.1 3.3.1 3.3.1
flutter_web_plugins flutter 0.0.0 0.0.0
fluttertoast ^8.2.2 8.2.4 8.2.4
html ^0.15.4 0.15.4 0.15.4
http ^0.13.6 0.13.6 1.1.2
http_parser ^4.0.2 4.0.2 4.0.2
image_gallery_saver ^1.7.1 1.7.1 2.0.3
image_picker ^1.0.1 1.0.4 1.0.4
intl ^0.18.0 0.18.1 0.18.1
meta ^1.9.1 1.10.0 1.11.0
numerus ^2.1.2 2.1.2 2.1.2
package_info ^2.0.2 2.0.2 2.0.2
path ^1.8.3 1.9.0 1.9.0
photo_view ^0.14.0 0.14.0 0.14.0
plugin_platform_interface ^2.1.5 2.1.7 2.1.7
protobuf ^2.1.0 2.1.0 3.1.0
provider ^6.0.5 6.1.1 6.1.1
pull_to_refresh ^2.0.0 2.0.0 2.0.0
sp_util ^2.0.3 2.0.3 2.0.3
sqflite ^2.3.0 2.3.0 2.3.0
typed_data ^1.3.2 1.3.2 1.3.2
universal_html ^2.2.3 2.2.4 2.2.4
url_launcher ^6.1.12 6.2.1 6.2.1
video_player ^2.7.0 2.8.1 2.8.1
webview_flutter ^4.2.2 4.4.2 4.4.2
webview_flutter_android ^3.9.2 3.12.1 3.12.1
webview_flutter_wkwebview ^3.7.2 3.9.4 3.9.4
Transitive dependencies
Package Constraint Compatible Latest
args - 2.4.2 2.4.2
async - 2.11.0 2.11.0
cached_network_image_platform_interface - 3.0.0 3.0.0
cached_network_image_web - 1.1.0 1.1.0
characters - 1.3.0 1.3.0
charcode - 1.3.1 1.3.1
clock - 1.1.1 1.1.1
cross_file - 0.3.3+8 0.3.3+8
cupertino_icons - 1.0.6 1.0.6
dbus - 0.7.10 0.7.10
ffi - 2.1.0 2.1.0
file - 7.0.0 7.0.0
file_selector_linux - 0.9.2+1 0.9.2+1
file_selector_macos - 0.9.3+3 0.9.3+3
file_selector_platform_interface - 2.6.1 2.6.1
file_selector_windows - 0.9.3+1 0.9.3+1
fixnum - 1.1.0 1.1.0
flutter_plugin_android_lifecycle - 2.0.17 2.0.17
image_picker_android - 0.8.8+2 0.8.8+2
image_picker_for_web - 3.0.1 3.0.1
image_picker_ios - 0.8.8+4 0.8.8+4
image_picker_linux - 0.2.1+1 0.2.1+1
image_picker_macos - 0.2.1+1 0.2.1+1
image_picker_platform_interface - 2.9.1 2.9.1
image_picker_windows - 0.2.1+1 0.2.1+1
js - 0.6.7 0.6.7
material_color_utilities - 0.5.0 0.8.0
mime - 1.0.4 1.0.4
nested - 1.0.0 1.0.0
octo_image - 2.0.0 2.0.0
package_info_plus - 5.0.1 5.0.1
package_info_plus_platform_interface - 2.0.1 2.0.1
path_provider - 2.1.1 2.1.1
path_provider_android - 2.2.1 2.2.1
path_provider_foundation - 2.3.1 2.3.1
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.1 2.1.1
path_provider_windows - 2.2.1 2.2.1
petitparser - 6.0.2 6.0.2
platform - 3.1.3 3.1.3
rxdart - 0.27.7 0.27.7
shared_preferences - 2.2.2 2.2.2
shared_preferences_android - 2.2.1 2.2.1
shared_preferences_foundation - 2.3.4 2.3.4
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.1 2.3.1
shared_preferences_web - 2.2.2 2.2.2
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
sqflite_common - 2.5.0+2 2.5.0+2
string_scanner - 1.2.0 1.2.0
synchronized - 3.1.0 3.1.0
term_glyph - 1.2.1 1.2.1
universal_io - 2.2.2 2.2.2
url_launcher_android - 6.2.0 6.2.0
url_launcher_ios - 6.2.1 6.2.1
url_launcher_linux - 3.1.0 3.1.0
url_launcher_macos - 3.1.0 3.1.0
url_launcher_platform_interface - 2.2.0 2.2.0
url_launcher_web - 2.2.1 2.2.1
url_launcher_windows - 3.1.0 3.1.0
uuid - 4.2.1 4.2.1
vector_math - 2.1.4 2.1.4
video_player_android - 2.4.10 2.4.10
video_player_avfoundation - 2.5.2 2.5.2
video_player_platform_interface - 6.2.1 6.2.1
video_player_web - 2.1.2 2.1.2
wakelock_plus - 1.1.4 1.1.4
wakelock_plus_platform_interface - 1.1.0 1.1.0
web - 0.3.0 0.4.0
webview_flutter_platform_interface - 2.8.0 2.8.0
win32 - 5.1.1 5.1.1
xdg_directories - 1.0.3 1.0.3
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^0.17.3` on csslib does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions csslib to update the constraint.

The constraint `^0.13.6` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

0/10 points: Package supports latest stable Dart and Flutter SDKs

  • Found no Flutter in your PATH. Could not determine the current Flutter version.

Analyzed with Pana 0.21.43, Dart 3.2.2.

Check the analysis log for details.