build_verify 2.0.0
build_verify: ^2.0.0 copied to clipboard

Test utility to ensure generated Dart code within a package is up-to-date when using package:build.

3
likes
110/ 130
pub points
80%
popularity

We analyzed this package on Sep 22, 2021, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 3 API elements (33.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:build_verify/build_verify.dart that imports:
  • package:build_verify/src/impl.dart that imports:
  • package:build_verify/src/utils.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
path^1.0.01.8.01.8.0
test^1.0.01.17.121.17.12
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-26.0.026.0.0
analyzer-2.3.02.3.0
args-2.3.02.3.0
async-2.8.22.8.2
boolean_selector-2.1.02.1.0
charcode-1.3.11.3.1
cli_util-0.3.30.3.3
collection-1.15.01.15.0
convert-3.0.13.0.1
coverage-1.0.31.0.3
crypto-3.0.13.0.1
file-6.1.26.1.2
frontend_server_client-2.1.22.1.2
glob-2.0.12.0.1
http_multi_server-3.0.13.0.1
http_parser-4.0.04.0.0
io-1.0.31.0.3
js-0.6.30.6.3
logging-1.0.21.0.2
matcher-0.12.110.12.11
meta-1.7.01.7.0
mime-1.0.01.0.0
node_preamble-2.0.12.0.1
package_config-2.0.22.0.2
pool-1.5.01.5.0
pub_semver-2.1.02.1.0
shelf-1.2.01.2.0
shelf_packages_handler-3.0.03.0.0
shelf_static-1.1.01.1.0
shelf_web_socket-1.0.11.0.1
source_map_stack_trace-2.1.02.1.0
source_maps-0.10.100.10.10
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
test_api-0.4.30.4.3
test_core-0.4.20.4.2
typed_data-1.3.01.3.0
vm_service-7.3.07.3.0
watcher-1.0.01.0.0
web_socket_channel-2.1.02.1.0
webkit_inspection_protocol-1.0.01.0.0
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.1+1, Dart 2.14.1.

3
likes
110
pub points
80%
popularity

Publisher

j832.com

Test utility to ensure generated Dart code within a package is up-to-date when using package:build.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

path, test

More

Packages that depend on build_verify