build_test 2.0.0
build_test: ^2.0.0 copied to clipboard

Utilities for writing unit tests of Builders.

4
likes
80 / 130
pub points
92 %
popularity

We analyzed this package on Apr 19, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 81 out of 113 API elements (71.7 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:build_test/build_test.dart that imports:
  • package:build_test/src/written_asset_reader.dart that imports:
  • package:build_test/src/in_memory_writer.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
async^2.5.02.5.02.5.0
build^2.0.02.0.02.0.0
build_config>=0.2.0 <0.5.00.4.70.4.7
build_resolvers^2.0.02.0.02.0.0
crypto^3.0.03.0.13.0.1
glob^2.0.02.0.12.0.1
html^0.15.00.15.00.15.0
logging^1.0.01.0.11.0.1
matcher^0.12.00.12.100.12.10
package_config^2.0.02.0.02.0.0
path^1.8.01.8.01.8.0
pedantic^1.10.01.11.01.11.0
stream_transform^2.0.02.0.02.0.0
test^1.16.01.16.81.16.8
test_core>=0.3.12 <0.4.00.3.190.3.19
watcher^1.0.01.0.01.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-20.0.020.0.0
args-2.0.02.0.0
boolean_selector-2.1.02.1.0
charcode-1.2.01.2.0
checked_yaml-2.0.12.0.1
cli_util-0.3.00.3.0
convert-3.0.03.0.0
coverage-1.0.21.0.2
csslib-0.17.00.17.0
file-6.1.06.1.0
graphs-1.0.02.0.0
http_multi_server-3.0.13.0.1
http_parser-4.0.04.0.0
io-1.0.01.0.0
js-0.6.30.6.3
json_annotation-4.0.14.0.1
meta-1.3.01.3.0
mime-1.0.01.0.0
node_preamble-2.0.02.0.0
pool-1.5.01.5.0
pub_semver-2.0.02.0.0
pubspec_parse-1.0.01.0.0
shelf-1.1.01.1.0
shelf_packages_handler-3.0.03.0.0
shelf_static-1.0.01.0.0
shelf_web_socket-1.0.11.0.1
source_map_stack_trace-2.1.02.1.0
source_maps-0.10.100.10.10
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
test_api-0.3.00.3.0
typed_data-1.3.01.3.0
vm_service-6.2.06.2.0
web_socket_channel-2.0.02.0.0
webkit_inspection_protocol-1.0.01.0.0
yaml-3.1.03.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Null safety support has one or more issues.

Package is not null safe

Because:

  • build_test that depends on:
  • build_config that doesn't opt in to null safety
For more information

Try running pub outdated --mode=null-safety. Be sure to read the migration guide.

Analysed with Pana 0.15.4, Dart 2.12.2.