bootpay 1.4.2
bootpay: ^1.4.2 copied to clipboard

A Bootpay plugin that provides payment api on Android, iOS and Web.

6
likes
95/ 130
pub points
72%
popularity

We analyzed this package on Oct 22, 2021, and awarded it 95 pub points (of a possible 130):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: Failed to run dartdoc

  • dartdoc failed with:
exitCode: 255
stdout: [2021-10-22T07:47:47.679868] Starting...
Documenting bootpay...
Initialized dartdoc with 985 libraries in 112.6 seconds
Generating docs for library bootpay_webview from package:bootpay/bootpay_webview.dart...
Generating docs for library bootpay_app from package:bootpay/shims/bootpay_app.dart...
Generating docs for library bootpay_api from package:bootpay/shims/bootpay_web.dart...
Generating docs for library bootpay_platform from package:bootpay/shims/bootpay_platform.dart...
Generating docs for library user_info from package:bootpay/user_info.dart...
Generating docs for library api_provider from package:bootpay/api/api_provider.dart...
Generating docs for library bootpay_simple_aes256 from package:bootpay/api/security/bootpay_simple_aes256.dart...
Generating docs for library bootpay_analytics from package:bootpay/api/bootpay_analytics.dart...
Generating docs for library bootpay_api from package:bootpay/bootpay_api.dart...
Generating docs for library payload from package:bootpay/model/payload.dart...
Generating docs for library user from package:bootpay/model/user.dart...
Generating docs for library item from package:bootpay/model/item.dart...
Generating docs for library stat_item from package:bootpay/model/stat_item.dart...
Generating docs for library onestore from package:bootpay/model/onestore.dart...
Generating docs for library extra from package:bootpay/model/extra.dart...
Generating docs for library bootpay from package:bootpay/bootpay.dart...
Documented 16 public libraries in 1.2 seconds

stderr:   warning: bootpay_api has no library level documentation comments
    from bootpay_api: (file:///tmp/pub-dartlang-dartdocFTMMVQ/pkg/lib/shims/bootpay_web.dart:3:9)
  error: failed to write file at: bootpay_api/bootpay_api-library.html
    for symbol bootpay_api: (file:///tmp/pub-dartlang-dartdocFTMMVQ/pkg/lib/bootpay_api.dart:1:1)
    conflicting with file already generated by bootpay_api: (file:///tmp/pub-dartlang-dartdocFTMMVQ/pkg/lib/shims/bootpay_web.dart:3:9)
            Dartdoc generates a path and filename to write to for each symbol.
            bootpay_api conflicts with another symbol in the generated path, and
            therefore can not be written out.  Changing the name, library name, or
            class name (if appropriate) of one of the conflicting items can resolve
            the conflict.   Alternatively, use the @nodoc tag in one symbol's
            documentation comments to hide it.
Found 1 warning and 1 error.
Unhandled exception:
encountered 1 errors
#0      Dartdoc.generateDocs (package:dartdoc/dartdoc.dart:241:9)
<asynchronous suspension>
#1      main (file:///project/pkg/pub_dartdoc/bin/pub_dartdoc.dart:33:19)
<asynchronous suspension>


Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:bootpay/bootpay.dart that imports:
  • package:bootpay/model/payload.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 15 issues. Showing the first 2:

lib/api/api_provider.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/api/bootpay_analytics.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bootpay_webview_flutter^2.1.32.1.32.1.3
encrypt^5.0.15.0.15.0.1
flutterflutter0.0.00.0.0
fluttertoast^8.0.88.0.88.0.8
http^0.13.40.13.40.13.4
js^0.6.30.6.30.6.3
package_info^2.0.22.0.22.0.2
shared_preferences^2.0.82.0.82.0.8
uuid^3.0.53.0.53.0.5
Transitive dependencies
PackageConstraintCompatibleLatest
args-2.3.02.3.0
asn1lib-1.0.21.0.2
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-3.0.13.0.1
crypto-3.0.13.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_web_plugins-0.0.00.0.0
http_parser-4.0.04.0.0
meta-1.7.01.7.0
path-1.8.01.8.0
path_provider_linux-2.1.02.1.0
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.32.0.3
platform-3.0.23.0.2
plugin_platform_interface-2.0.22.0.2
pointycastle-3.3.43.3.4
process-4.2.44.2.4
shared_preferences_linux-2.0.22.0.2
shared_preferences_macos-2.0.22.0.2
shared_preferences_platform_interface-2.0.02.0.0
shared_preferences_web-2.0.22.0.2
shared_preferences_windows-2.0.22.0.2
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
win32-2.2.102.2.10
xdg_directories-0.2.00.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.