bloc_test 7.1.0
bloc_test: ^7.1.0

Dart native js
Flutter Android iOS web

A testing library which makes it easy to test blocs. Built to be used with the bloc state management package.

104
likes
100 / 110
pub points
95 %
popularity

We analyzed this package on Dec 3, 2020, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 8 API elements (75.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'onError' is deprecated and shouldn't be used. Use runZonedGuarded instead.

lib/src/bloc_test.dart:181:5

    ╷
181 │     onError: (Object error) {
    │     ^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/bloc_test.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bloc^6.0.06.1.06.1.0
meta^1.1.81.3.0-nullsafety.61.3.0-nullsafety.6
mockito^4.1.24.1.34.1.3
test^1.14.21.16.0-nullsafety.121.16.0-nullsafety.12
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-12.0.014.0.0
analyzer-0.40.60.41.1
args-1.6.01.6.0
async-2.5.0-nullsafety.32.5.0-nullsafety.3
boolean_selector-2.1.0-nullsafety.32.1.0-nullsafety.3
build-1.5.21.5.2
built_collection-4.3.24.3.2
built_value-7.1.07.1.0
charcode-1.2.0-nullsafety.31.2.0-nullsafety.3
cli_util-0.2.00.2.0
code_builder-3.5.03.5.0
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
convert-2.1.12.1.1
crypto-2.1.52.1.5
dart_style-1.3.101.3.10
file-5.2.15.2.1
fixnum-0.10.110.10.11
glob-1.2.01.2.0
http_multi_server-2.2.02.2.0
http_parser-3.1.43.1.4
intl-0.16.10.16.1
io-0.3.40.3.4
js-0.6.3-nullsafety.30.6.3-nullsafety.3
logging-0.11.40.11.4
matcher-0.12.10-nullsafety.30.12.10-nullsafety.3
mime-0.9.70.9.7
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
node_preamble-1.4.121.4.12
package_config-1.9.31.9.3
path-1.8.0-nullsafety.31.8.0-nullsafety.3
pool-1.5.0-nullsafety.31.5.0-nullsafety.3
pub_semver-1.4.41.4.4
quiver-2.1.52.1.5
shelf-0.7.90.7.9
shelf_packages_handler-2.0.02.0.0
shelf_static-0.2.80.2.8
shelf_web_socket-0.2.30.2.3
source_gen-0.9.90.9.9
source_map_stack_trace-2.1.0-nullsafety.42.1.0-nullsafety.4
source_maps-0.10.10-nullsafety.30.10.10-nullsafety.3
source_span-1.8.0-nullsafety.41.8.0-nullsafety.4
stack_trace-1.10.0-nullsafety.61.10.0-nullsafety.6
stream_channel-2.1.0-nullsafety.32.1.0-nullsafety.3
string_scanner-1.1.0-nullsafety.31.1.0-nullsafety.3
term_glyph-1.2.0-nullsafety.31.2.0-nullsafety.3
test_api-0.2.19-nullsafety.60.2.19-nullsafety.6
test_core-0.3.12-nullsafety.110.3.12-nullsafety.11
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vm_service-5.5.05.5.0
watcher-0.9.7+150.9.7+15
web_socket_channel-1.1.01.1.0
webkit_inspection_protocol-0.7.40.7.4
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

104
likes
100
pub points
95%
popularity

Publisher

bloclibrary.dev

A testing library which makes it easy to test blocs. Built to be used with the bloc state management package.

Homepage
Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

MIT (LICENSE)

Dependencies

bloc, meta, mockito, test

More

Packages that depend on bloc_test