bloc_test 7.1.0
bloc_test: ^7.1.0 copied to clipboard

Dart native js
Flutter Android iOS web

A testing library which makes it easy to test blocs. Built to be used with the bloc state management package.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  bloc_test: ^7.1.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:bloc_test/bloc_test.dart';
120
likes
100
pub points
95%
popularity

Publisher

bloclibrary.dev

A testing library which makes it easy to test blocs. Built to be used with the bloc state management package.

Homepage
Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

MIT (LICENSE)

Dependencies

bloc, meta, mockito, test

More

Packages that depend on bloc_test