automatic_version_upgrader 0.1.0+8 icon indicating copy to clipboard operation
automatic_version_upgrader: ^0.1.0+8 copied to clipboard

A command line interface to upgrade your app version automatically in a CI/CD flow.

7
likes
140/ 140
pub points
21%
popularity

We analyzed this package 4 days ago, and awarded it 140 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 47 out of 52 API elements (90.4 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:automatic_version_upgrader/automatic_version_upgrader.dart that imports:
  • package:automatic_version_upgrader/src/helpers/helpers.dart that imports:
  • package:automatic_version_upgrader/src/helpers/change_pubspec_version.dart that imports:
  • package:mason_logger/mason_logger.dart that imports:
  • package:mason_logger/src/mason_logger.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
app_store_connect_app_versions^0.1.0+10.1.0+10.1.0+1
args^2.3.12.3.12.3.1
equatable^2.0.32.0.52.0.5
googleapis^9.1.09.2.09.2.0
googleapis_auth^1.3.11.3.11.3.1
gradle_properties^1.0.01.0.01.0.0
http^0.13.50.13.50.13.5
mason_logger^0.1.10.1.30.1.3
meta^1.8.01.8.01.8.0
pub_semver^2.1.12.1.12.1.1
pub_updater^0.2.20.2.20.2.2
pubspec^2.3.02.3.02.3.0
universal_io^2.0.42.0.42.0.4
usage^4.1.04.1.04.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
_discoveryapis_commons-1.0.31.0.3
asn1lib-1.1.11.1.1
async-2.9.02.9.0
collection-1.16.01.16.0
convert-3.0.23.0.2
crypto-3.0.23.0.2
crypto_keys-0.3.00.3.0
dart_jsonwebtoken-2.4.22.4.2
file-6.1.46.1.4
http_parser-4.0.14.0.1
jose-0.3.20.3.2
js-0.6.40.6.4
json_annotation-4.7.04.7.0
matcher-0.12.120.12.12
path-1.8.21.8.2
platform-3.1.03.1.0
pointycastle-3.6.23.6.2
process-4.2.44.2.4
quiver-3.1.03.1.0
source_span-1.9.11.9.1
stack_trace-1.10.01.10.0
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
uri-1.0.01.0.0
x509-0.2.20.2.2
yaml-3.1.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.18, Dart 2.18.2.