automated_testing_framework_plugin_strings 1.0.1
automated_testing_framework_plugin_strings: ^1.0.1

Flutter Android iOS

Library to use provide string generation and maipulation capabilities to the testing framework.

0
likes
100 / 110
pub points
59 %
popularity

We analyzed this package on Nov 24, 2020, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 27 out of 64 API elements (42.2 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:automated_testing_framework_plugin_strings/automated_testing_framework_plugin_strings.dart that imports:
  • package:automated_testing_framework_plugin_strings/src/test_strings_helper.dart that imports:
  • package:automated_testing_framework/automated_testing_framework.dart that imports:
  • package:automated_testing_framework/src/report/models/test_device_info_helper.dart that imports:
  • package:package_info/package_info.dart that declares support for platforms: Android, iOS, macOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
automated_testing_framework^1.2.91.2.18+31.2.18+3
form_validation^1.0.11.0.21.0.2
intl^0.16.10.16.10.16.1
json_class^1.0.6+11.0.71.0.7
json_theme^1.3.3+11.4.21.4.2
logging^0.11.40.11.40.11.4
meta^1.1.81.3.0-nullsafety.61.3.0-nullsafety.6
static_translations^1.0.31.0.31.0.3
Transitive dependencies
PackageConstraintCompatibleLatest
args-1.6.01.6.0
async-2.4.22.5.0-nullsafety.3
automated_testing_framework_models-1.0.0+21.0.0+2
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.2.0-nullsafety.3
child_builder-1.0.0+21.0.0+2
cli_repl-0.2.0+10.2.0+1
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
colorize-2.0.02.0.0
convert-2.1.12.1.1
crypto-2.1.52.1.5
dart2_constant-1.0.2+dart21.0.2+dart2
device_info-1.0.01.0.0
device_info_platform_interface-1.0.11.0.1
file-5.2.15.2.1
fluri-1.3.01.3.0
glob-1.2.01.2.0
http-0.12.20.12.2
http_parser-3.1.43.1.4
js-0.6.20.6.2
json_schema-2.2.12.2.1
matcher-0.12.90.12.10-nullsafety.3
mime-0.9.70.9.7
nested-0.0.40.0.4
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.31.9.3
package_info-0.4.3+20.4.3+2
package_resolver-1.0.101.0.10
path-1.7.01.8.0-nullsafety.3
pedantic-1.9.21.9.2
pigment-1.0.31.0.3
plugin_platform_interface-1.0.31.0.3
pointycastle-2.0.02.0.0
provider-4.3.2+24.3.2+2
quiver-2.1.52.1.5
rest_client-1.0.6+11.0.6+1
sass-1.29.01.29.0
sockjs_client-0.3.50.3.5
sockjs_client_wrapper-1.0.141.0.14
source_maps-0.10.90.10.9
source_span-1.7.01.8.0-nullsafety.4
stack_trace-1.9.61.10.0-nullsafety.6
stream_transform-1.2.01.2.0
string_scanner-1.0.51.1.0-nullsafety.3
term_glyph-1.1.01.2.0-nullsafety.3
tinycolor-1.0.31.0.3
tuple-1.0.31.0.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
uri-0.11.3+10.11.3+1
utf-0.9.0+50.9.0+5
uuid-2.2.22.2.2
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5
w_common-1.20.31.20.3
w_transport-3.2.83.2.8
watcher-0.9.7+150.9.7+15
websafe_platform-1.0.51.0.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs