automated_testing_framework_example 2.1.0+2
automated_testing_framework_example: ^2.1.0+2 copied to clipboard

Example project for the Automated Testing Framework that provides a reusable example across add ons.

0
likes
110/ 130
pub points
40%
popularity

We analyzed this package on Oct 25, 2021, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 11 out of 53 API elements (20.8 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:automated_testing_framework_example/automated_testing_framework_example.dart that imports:
  • package:automated_testing_framework_example/src/pages/stacked_scroll_page.dart that imports:
  • package:automated_testing_framework/widgets.dart that imports:
  • package:automated_testing_framework/src/widgets/testable_text_form_field.dart that imports:
  • package:automated_testing_framework/automated_testing_framework.dart that imports:
  • package:automated_testing_framework/src/report/models/test_device_info_helper.dart that imports:
  • package:device_info/device_info.dart that declares support for platforms: Android, iOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
automated_testing_framework^3.1.0+33.1.1+13.1.1+1
flutterflutter0.0.00.0.0
flutter_slidable^0.6.00.6.00.6.0
form_validation^2.0.02.0.0+12.0.0+1
intl^0.17.00.17.00.17.0
logging^1.0.21.0.21.0.2
meta^1.7.01.7.01.7.0
provider^6.0.06.0.16.0.1
static_translations^2.0.2+12.0.2+22.0.2+2
Transitive dependencies
PackageConstraintCompatibleLatest
args-2.3.02.3.0
async-2.8.22.8.2
automated_testing_framework_models-2.0.82.0.8
characters-1.1.01.2.0
charcode-1.3.11.3.1
child_builder-2.0.02.0.0
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-3.0.13.0.1
crypto-3.0.13.0.1
device_info-2.0.22.0.2
device_info_platform_interface-2.0.12.0.1
ffi-1.1.21.1.2
flutter_markdown-0.6.80.6.8
flutter_web_plugins-0.0.00.0.0
http-0.13.40.13.4
http_parser-4.0.04.0.0
js-0.6.30.6.3
json_class-2.0.0+22.0.0+2
json_schema2-2.0.0+32.0.0+3
json_theme-3.0.13.0.1
markdown-4.0.04.0.0
matcher-0.12.110.12.11
nested-1.0.01.0.0
package_info_plus-1.3.01.3.0
package_info_plus_linux-1.0.31.0.3
package_info_plus_macos-1.3.01.3.0
package_info_plus_platform_interface-1.0.21.0.2
package_info_plus_web-1.0.41.0.4
package_info_plus_windows-1.0.41.0.4
path-1.8.01.8.0
plugin_platform_interface-2.0.22.0.2
pointycastle-3.3.43.3.4
quiver-3.0.1+13.0.1+1
rest_client-2.0.1+32.0.1+3
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uri-1.0.01.0.0
uuid-3.0.53.0.5
vector_math-2.1.02.1.1
win32-2.2.102.2.10

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.