apptive_grid_grid_builder 2.0.2 copy "apptive_grid_grid_builder: ^2.0.2" to clipboard
apptive_grid_grid_builder: ^2.0.2 copied to clipboard

A Flutter Package to build Widgets based on Data from an ApptiveGrid Grid.

3
likes
140/ 140
pub points
30%
popularity

We analyzed this package 19 hours ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

639 out of 673 API elements (94.9 %) have documentation comments.

Some symbols that are missing documentation: apptive_grid_grid_builder, apptive_grid_grid_builder.ActorFilter.fieldId, apptive_grid_grid_builder.ActorFilter.operator, apptive_grid_grid_builder.ActorFilter.value, apptive_grid_grid_builder.AllOfFilter.fieldId.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:apptive_grid_grid_builder/apptive_grid_grid_builder.dart that imports:
  • package:apptive_grid_grid_builder/src/apptive_grid_grid_builder.dart that imports:
  • package:apptive_grid_core/apptive_grid_core.dart that imports:
  • package:apptive_grid_core/src/apptive_grid_network.dart that imports:
  • package:apptive_grid_core/src/network/apptive_grid_client.dart that imports:
  • package:apptive_grid_core/src/network/authentication/apptive_grid_authenticator.dart that imports:
  • package:uni_links/uni_links.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:apptive_grid_grid_builder/apptive_grid_grid_builder.dart that imports:
  • package:apptive_grid_grid_builder/src/apptive_grid_grid_builder.dart that imports:
  • package:apptive_grid_core/apptive_grid_core.dart that imports:
  • package:apptive_grid_core/src/apptive_grid_network.dart that imports:
  • package:apptive_grid_core/src/network/apptive_grid_client.dart that imports:
  • package:apptive_grid_core/src/network/authentication/apptive_grid_authenticator.dart that imports:
  • package:uni_links/uni_links.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:apptive_grid_grid_builder/apptive_grid_grid_builder.dart that imports:
  • package:apptive_grid_grid_builder/src/apptive_grid_grid_builder.dart that imports:
  • package:apptive_grid_core/apptive_grid_core.dart that imports:
  • package:apptive_grid_core/src/apptive_grid_network.dart that imports:
  • package:apptive_grid_core/src/network/apptive_grid_client.dart that imports:
  • package:apptive_grid_core/src/network/authentication/apptive_grid_authenticator.dart that imports:
  • package:uni_links/uni_links.dart that declares support for platforms: Android, iOS, Web.
Package not compatible with platform Web

Because:

  • package:apptive_grid_grid_builder/apptive_grid_grid_builder.dart that imports:
  • package:apptive_grid_grid_builder/src/apptive_grid_grid_builder.dart that imports:
  • package:apptive_grid_core/apptive_grid_core.dart that imports:
  • package:apptive_grid_core/src/apptive_grid_network.dart that imports:
  • package:apptive_grid_core/src/network/authentication/web_auth_enabler/web_auth_enabler.dart that imports:
  • package:apptive_grid_core/src/network/authentication/web_auth_enabler/configure_web.dart that imports:
  • package:apptive_grid_core/src/network/authentication/apptive_grid_authenticator.dart that imports:
  • package:apptive_grid_core/src/network/authentication/authentication_storage.dart that imports:
  • package:flutter_secure_storage/flutter_secure_storage.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
apptive_grid_core ^2.1.1 2.1.1 2.1.1
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
archive - 3.4.10 3.4.10
args - 2.4.2 2.4.2
asn1lib - 1.5.2 1.5.2
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
crypto_keys - 0.3.0+1 0.3.0+1
ffi - 2.1.2 2.1.2
fixnum - 1.1.0 1.1.0
flutter_secure_storage - 9.0.0 9.0.0
flutter_secure_storage_linux - 1.2.0 1.2.0
flutter_secure_storage_macos - 3.0.1 3.0.1
flutter_secure_storage_platform_interface - 1.0.2 1.0.2
flutter_secure_storage_web - 1.1.2 1.1.2
flutter_secure_storage_windows - 3.0.0 3.0.0
flutter_web_plugins - 0.0.0 0.0.0
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
image - 4.1.7 4.1.7
intl - 0.18.1 0.19.0
jose - 0.3.4 0.3.4
js - 0.6.7 0.7.1
logging - 1.2.0 1.2.0
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
mime - 1.0.5 1.0.5
nested - 1.0.0 1.0.0
openid_client - 0.4.8 0.4.8
path - 1.9.0 1.9.0
path_provider - 2.1.2 2.1.2
path_provider_android - 2.2.2 2.2.2
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
petitparser - 6.0.2 6.0.2
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
pointycastle - 3.7.4 3.7.4
provider - 6.1.1 6.1.1
quiver - 3.2.1 3.2.1
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.0
typed_data - 1.3.2 1.3.2
uni_links - 0.5.1 0.5.1
uni_links_platform_interface - 1.0.0 1.0.0
uni_links_web - 0.1.0 0.1.0
universal_file - 1.0.0 1.0.0
universal_platform - 1.0.0+1 1.0.0+1
url_launcher - 6.2.5 6.2.5
url_launcher_android - 6.3.0 6.3.0
url_launcher_ios - 6.2.4 6.2.4
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.1.0 3.1.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.0 2.3.0
url_launcher_windows - 3.1.1 3.1.1
uuid - 4.3.3 4.3.3
vector_math - 2.1.4 2.1.4
web - 0.5.0 0.5.0
win32 - 5.2.0 5.2.0
x509 - 0.2.4+2 0.2.4+2
xdg_directories - 1.0.4 1.0.4
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.0, Flutter 3.19.0, Dart 3.3.0.

Check the analysis log for details.

3
likes
140
pub points
30%
popularity

Publisher

verified publisherapptivegrid.de

A Flutter Package to build Widgets based on Data from an ApptiveGrid Grid.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

apptive_grid_core, flutter

More

Packages that depend on apptive_grid_grid_builder