angular_quill 0.1.4
angular_quill: ^0.1.4 copied to clipboard

Angular dart component for the Quill rich text editor. Quill is a free, open source WYSIWYG editor built for the modern web.

3
likes
70 / 130
pub points
61 %
popularity

We analyzed this package on May 4, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 32 API elements (18.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:angular_quill/angular_quill.dart that imports:
  • package:angular_quill/src/quill/quill_component.dart that imports:
  • package:angular_quill/src/quill/quill.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 10 issues. Showing the first 2:

INFO: Avoid const keyword.

lib/angular_quill.dart:4:30

  ╷
4 │ const List quillDirectives = const [QuillValueAccessor, QuillComponent];
  │                              ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/angular_quill.dart

INFO: Avoid const keyword.

lib/src/quill/quill_component.dart:11:51

   ╷
11 │   @Directive(selector: 'quill[ngModel]', providers: const [
   │ ┌───────────────────────────────────────────────────^
12 │ │   const Provider(ngValueAccessor, useExisting: QuillValueAccessor, multi: true)
13 │ │ ])
   │ └─^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/quill/quill_component.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angular>=5.0.0 <7.0.06.0.16.0.1
angular_forms>=2.0.0 <=4.0.03.0.03.0.0
js^0.6.1+10.6.30.6.3
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-12.0.021.0.0
analyzer-0.40.61.5.0
angular_ast-1.0.11.0.1
angular_compiler-1.0.11.0.1
args-1.6.02.1.0
async-2.6.12.6.1
build-1.6.22.0.1
build_config-0.4.71.0.0
built_collection-5.0.05.0.0
built_value-8.0.58.0.5
charcode-1.2.01.2.0
checked_yaml-1.0.42.0.1
cli_util-0.2.00.3.0
code_builder-3.7.04.0.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
csslib-0.16.20.17.0
dart_style-1.3.102.0.1
file-5.2.16.1.0
fixnum-1.0.01.0.0
glob-1.2.02.0.1
intl-0.16.10.17.0
json_annotation-4.0.14.0.1
logging-0.11.41.0.1
matcher-0.12.100.12.10
meta-1.3.01.3.0
node_interop-1.2.12.0.1
node_io-1.2.02.0.0
package_config-1.9.32.0.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
pub_semver-1.4.42.0.0
pubspec_parse-0.1.81.0.0
source_gen-0.9.10+21.0.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-0.9.7+151.0.0
yaml-2.2.13.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.

3
likes
70
pub points
61%
popularity

Angular dart component for the Quill rich text editor. Quill is a free, open source WYSIWYG editor built for the modern web.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

adam.lofts@gmail.com

License

BSD (LICENSE)

Dependencies

angular, angular_forms, js

More

Packages that depend on angular_quill