angular_quill 0.1.2

  • Readme
  • Changelog
  • Installing
  • 77

Angular Quill #

An angular dart component for the Quill rich text editor

See it in action #

Visit https://adamlofts.github.io/angular_quill_example/build/web/index.html

And view the corresponding example source code.

Usage #

Add the dependency to pub:

dependencies:
  angular_quill:

Add the component to your template

<my-app>
    <quill
            [(ngModel)]="html"
            placeholder="Write something..."
            (blur)="blur()"
            (input)="input()"
    ></quill>
</my-app>

Add quillDirectives to the directives on your app component

@Component(
  selector: 'my-app',
  templateUrl: 'app_component.html',
  directives: const [COMMON_DIRECTIVES, quillDirectives],
)
class AppComponent {}

Include Quill JS and css files in your app html.

  <head>
    <script src="packages/angular_quill/quill-1.2.4/quill.min.js"></script>
    <link rel="stylesheet" href="packages/angular_quill/quill-1.2.4/quill.snow.css">
  </head>

Changelog #

0.1.2 #

  • Fix type of off to fix crash when destroying component in DDC.
  • Dart fmt

0.1.1 #

  • Add build.yaml file so theme css files are included in build.

0.1.0 #

  • Upgrade to dart 2 and angular 5

0.0.6 #

  • Upgrade to angular 4.0.0

0.0.5 #

  • Update README

0.0.3 #

  • Split example out of main repo

0.0.1 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angular_quill: ^0.1.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:angular_quill/angular_quill.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
75
Health:
Code health derived from static analysis. [more]
97
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
51
Overall:
Weighted score of the above. [more]
77
Learn more about scoring.

We analyzed this package on Jan 20, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4

Health suggestions

Fix lib/src/quill/quill_component.dart. (-2.96 points)

Analysis of lib/src/quill/quill_component.dart reported 6 hints, including:

line 10 col 51: Avoid const keyword.

line 11 col 3: Avoid const keyword.

line 106 col 34: Unnecessary new keyword.

line 110 col 35: Unnecessary new keyword.

line 119 col 19: Unnecessary new keyword.

Fix lib/angular_quill.dart. (-0.50 points)

Analysis of lib/angular_quill.dart reported 1 hint:

line 4 col 30: Avoid const keyword.

Maintenance suggestions

Package is getting outdated. (-38.63 points)

The package was last published 72 weeks ago.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and angular_quill.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
angular ^5.0.0 5.3.1 6.0.0-alpha+1
angular_forms ^2.0.0 2.1.2 2.1.4
js ^0.6.1+1 0.6.1+1
Transitive dependencies
analyzer 0.35.4 0.39.4
angular_ast 0.5.9 0.5.11
angular_compiler 0.4.3 0.4.5
args 1.5.2
async 2.4.0
build 1.2.2
build_config 0.4.1+1
built_collection 4.3.2
built_value 7.0.8
charcode 1.1.2
checked_yaml 1.0.2
code_builder 3.2.1
collection 1.14.12
convert 2.1.1
crypto 2.1.4
csslib 0.14.6+1 0.16.1
dart_style 1.2.4 1.3.3
fixnum 0.10.11
front_end 0.1.14 0.1.29
glob 1.2.0
intl 0.15.8 0.16.1
json_annotation 3.0.1
kernel 0.3.14 0.3.29
logging 0.11.4
matcher 0.12.6
meta 1.1.8
node_interop 1.0.3
node_io 1.0.1+2
package_config 1.1.0
path 1.6.4
pedantic 1.9.0
pub_semver 1.4.2
pubspec_parse 0.1.5
quiver 2.1.2+1
source_gen 0.9.4+4 0.9.4+7
source_span 1.6.0
stack_trace 1.9.3
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
watcher 0.9.7+13
yaml 2.2.0